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SQL MANAGEMENT STUDIO EXPRESS 

Preparing the SQL Server Database 
There are several steps to set up a scheduled backup. You must perform these steps at the server hosting the SQL 
database.  

Before starting this procedure there are a number of items to prepare. Complete these steps before moving on as 
they will be used later. 

Find the SQL Server and Database Names 
This information is easily available from inside the Practice Management software. 

1. Go Help > About ProSystem fx Practice Management. 
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2. Click Additional Info… on the About ProSystem fx Practice Management dialog. 

 
3. Write down the Host Server and Host Database from the About dialog. If there is more than one 

database in use, perform this step for each database.  

 
4. Create a folder on a local drive of the server hosting the Practice Management SQL Server to store the 

Backup file and the files created in this document. 

5. Decide on a time to perform the backup. Schedule the backup when no staff are logged in to the Practice 
Management software. 

Note: The backup may be included as a part of a subsequent separate backup, if needed. 

6. Locate the ‘sa’ account password in the SQL Administrator account. If no changes have been made to the 
default information, the password is PracticeUser1.  
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Download and Install SQL Management Studio Express  
SQL Management Studio Express is a free download from the Microsoft Web site. Follow these instructions to 
download and install SQL Management Studio Express on your server. 

Download SQL Management Express: 

1. Go to http://www.microsoft.com 

2. Select Downloads > Download Center. 

3. Enter Management Studio in the search box to find a list of available downloads. One of the first results will 
be Microsoft® SQL Server® 2008 Management Studio Express. If preferred, Microsoft® SQL Server® 2005 
Management Studio Express is also compatible with ProSystem fx Practice Management. 

4. Select Microsoft® SQL Server® 2008 Management Studio Express and read the Overview and Instructions.  

Note: The ProSystem fx Practice Management installation also installs SQL Server and .NET Framework 2.0 
to the Server. 

5. Download this tool to the Server 

Install SQL Management Express: 

Once the tool is downloaded, you are ready to install.  

1. Click Run. A wizard displays walking you through the installation process.  

2. Accept the license agreement and follow the instructions to install SQL Server Management Studio Express on 
your server.  

Note: It does not need to be installed on a workstation also. 

  

http://www.microsoft.com/�
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BACKING UP PROSYSTEM FX MANAGEMENT 

Creating a Back Up Script with Management Studio 
Follow these instructions to make a single backup. You will create a script file that will then be used to make the 
scheduled backup. If more than one database needs to be backed up, you must repeat these steps for each database, 
and create a separate script file each time. 

1. Select Start > Programs > Microsoft SQL Server 2005 or 2008 > Server Management Studio Express. 
The Connect to Server dialog displays. 

 
2. Select the Host server from the drop-down list. If it is not in the list, enter the information in the Server name 

field.  

3. Select SQL Server Authentication in the Authentication field and enter the SQL Administrator account (sa) 
user name and password.  

4. Click Connect. 

5. Click Databases in the Object Explorer dialog to expand the list of available SQL databases. 
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6. Right-click your firm’s ProSystem fx Practice Management SQL database and select Tasks > Back Up. The 
Back Up Database dialog displays. 

 
7. Select the General page in the left navigation area.  

 

a. Verify the Database name in the Name field. The ProSystem fx Practice Management SQL database 
selected in the previous step is selected by default.  

Note: Master, Model, Tempdb, and MSDB are also listed as databases to backup. These four 
databases are system databases and should not be backed up for this procedure. 
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b. Enter a description of the backup in the Description box, if preferred. 

c. Verify that the default value of 0 is specified in the Backup set will expire > After box.  

d. Select Disk in the Destination section.  

Note: The destination box may already list a file in the Back up to box. If so, click Remove to delete 
the path listed.  

e. Click Add to  add the correct path. The Select Backup Destination dialog will open.  

i. Click the … browse button to open a folder tree. . 

ii. Browse to the folder created for the backup and enter the name of the file in the File name 
field.  

iii. Add .BAK to the end of the file name.  

iv. Click OK to close the window and click OK on the Select Backup Destination window. The 
path and file name will now be listed in the Destination grid. 
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8. Select the Options page in the left navigation area to set Overwrite and Reliability options. 

 

a. Select Back up to the existing media set and Overwrite all existing backup sets. 

b. Select Verify the backup when it is finished to make sure your backup will be available should you 
need to restore it. This option may make the backup process significantly longer.  

Note: If a test run is wanted, click OK. The backup will run, but the script file will not be created. If test is run, 
steps 6 through 8 must be repeated. 

9. Select Script > Script Action to File to save your backup instructions to a Script so you can select the script 
to run the backup in the future. 

 
10. Browse to the location of the backup file. 

11. Enter the name of your backup script and click Save. Your script will be saved with a .SQL file extension. 
Repeat this process for each database requiring a backup, with a different name for each script. 
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Running a Back Up Script with a Batch File 
This script file will run the batch file you created in the previous section. Multiple databases can be backed up by 
adding the command to the batch file for each script file. 

1. Open Notepad. 

2. Enter the following command: 

  SQLCMD.EXE -SYourServer\Instance -Usa -Ppassword -i “path\script.sql”  

• YourServer\Instance is the host server found earlier. 

•  Password is the sa password 

•  “path\script.sql” is the path to the script file plus the script file’s name. Make sure to have quotes 
before and after this item. 

Note: The command is case sensitive and the “–S”, “-U” and “-P” must be upper case while the “-i” and “sa” 
are lowercase. 

3. Test the command. 

a. Click Start > Programs > Accessories > Command Prompt.  

b. Copy the command from the text file and paste it in the command prompt window. 

c. Press the Enter key  to test for errors.  

If the prompt does not run correctly, review and correct the command text in your text file. 

4. Select File > Save As.  

5. Browse to the folder you wish to save the batch file. 

6. Enter the name of the batch file with the file extension .bat.  

7. Click Save. 

Note: To run the batck file, double-click the file in Windows Explorer. A dialog opens with a black background, 
showing numbers counting to one hundred by tens. The Windows folder option Hide extensions for 
known file types must be disabled to view the file.  

Scheduling a Batch File 
Use the following instructions to set up a task in Windows Task Scheduler to run the batch file. These specific 
instructions are for Server 2008. Other versions of Windows have similar functionality.  

1. Click Start > All Programs > Accessories > System Tools > Task Scheduler. 

2. The Task Scheduler dialog opens. Click Action > Create Basic Task… 
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3. Enter  a descriptive name in the Name box, and click Next. 

 
4. Leave Daily selected on the Trigger page, and click Next. 
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5. Enter the start time for the backup, leave the Recur Every option at one day, and click Next. 

 
6. Leave Start a program selected and click Next. 
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7. Click Browse and browse to the batch file you created earlier. Select the batch file, click Open, and then click 
Next. 

 
8. Select the Open the Properties dialog for this task when I click Finish box  and click Finish. The Properties 

dialog opens. 
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9. On the general tab, select Run whether user is logged on or not and check Run with highest privileges. 

 
10. Click OK.  

11. Enter the user name and password for the Windows user account, and click OK.  

 
To test the task, right-clicking it in Task Scheduler and click Run.  

Notes:  

• The Windows user account you log in to must have local administrator permissions. 

• Check the backup file for a changed modified date for the first few days to make sure the task is 
running as scheduled. 

• If the password for the Windows account changes, then reopen this task and enter the user name 
and new password. 
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Other Items to Backup 
The Practice Management server install folder is called CPAS. We recommend backing up this folder with the 
database during your normal nightly backup process. Recovering the folder and its files will make recovering from a 
major server issue easier and quicker.  

If the entire folder cannot be backed up, there are two folders that should be backed up: 

• CPAS\vpm\rtf folder, which is named the same as the database.  

• CPAS\vpm\images folder, if pictures are used in the header or footer of invoices and statements.  

These items will need to be backed up using the server backup procedure.  

Moving and Renaming the Backup 
The backup process described above creates the backup on the same machine as the SQL server. If you do not store 
the backup in an additional location, it can be lost during a major server issue.  

Tip: It is advised to include the backup file in the normal nightly backups for the server. Moving the backup file off the 
server is the only way to make sure it is available in the event of a major server issue. 

You can also create a batch file that will move the backup file to another location, such as a network drive. The 
backup process described below overwrites the backup file created the last time the script ran. This prevents the 
backups from overusing hard drive space. Occassionally, it is useful, or required, to keep multiple backups for a 
database. Use the following procedure to make a batch file that will: 

• Move a backup file to a new location 

• Add the date and time to the file name 

Do create the batch file, do the following: 

1. Open Notepad. 

2. Enter the following command: 

Copy “OriginalBackuplocation\BackupFile.BAK” “NewBackupFolder” 

@echo off 

for /F "tokens=2-4 delims=/ " %%i in ('date /t') do set yyyymmdd=%%k%%i%%j 

echo Date: %yyyymmdd% 

for /F "tokens=1-2 delims=: " %%l in ('time /t') do set hhmm=%%l%%m 

echo Time: %hhmm% 

REM -- or use both 

echo %yyyymmdd%%hhmm% 

rem -- here is the copy command with just the date appended 

RENAME “NewBackupFolder\BackupFile.BAK” BackupFile%yyyymmdd%%hhmm%.BAK 

• OriginalBackuplocation – Folder path to the location the backup is created in.  

• BackupFile – name of the file created by the backup process. Do not include the BAK extension.  

• NewBackupFolder – folder path or storing the backup files. 

3. Test the command. 

a. Click Start > Programs > Accessories > Command Prompt.  
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b. Copy the command from the text file and paste it in the command prompt window. 

c. Press the Enter key  to test for errors.  

If the prompt does not run correctly, review and correct the command text in your text file. 

4. Select File > Save As.  

5. Browse to the folder you wish to save the batch file. 

6. Enter the name of the batch file with the file extension .bat.  

7. Click Save. 

8. Set up a separate scheduled task for this batch file and schedule it after the backup task has been completed.  
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