Adobe Acrobat DC will not open while the CCH® ProSystem fx® Engagement or Workpaper Manager plugin is loaded.
- Article Type:
- Problem Resolution
- Last Modified:
- 03/27/2023
Symptoms
There are two known causes for this behavior:
Or
- Event Viewer shows:
"Faulting application name: Acrobat.exe, version: 20.9.20063.54258, time stamp: 0x5eaf4d63
Faulting module name: PfxEngagementx.api, version: 2019.2.1105.0, time stamp: 0x5e41df51
Exception code: 0xc0000005
Fault offset: 0x0000f38d
Faulting process id: 0xfc4
Faulting application start time: 0x01d62d269f2d477f
Faulting application path: C:\Program Files (x86)\Adobe\Acrobat DC\Acrobat\Acrobat.exe
Faulting module path: C:\Program Files (x86)\Adobe\Acrobat DC\Acrobat\plug_ins\PfxEngagementx.api
Report Id: dc713258-af53-41f2-b034-725a43f3a6d7
Faulting package full name:
Faulting package-relative application ID:"
Faulting module name: PfxEngagementx.api, version: 2019.2.1105.0, time stamp: 0x5e41df51
Exception code: 0xc0000005
Fault offset: 0x0000f38d
Faulting process id: 0xfc4
Faulting application start time: 0x01d62d269f2d477f
Faulting application path: C:\Program Files (x86)\Adobe\Acrobat DC\Acrobat\Acrobat.exe
Faulting module path: C:\Program Files (x86)\Adobe\Acrobat DC\Acrobat\plug_ins\PfxEngagementx.api
Report Id: dc713258-af53-41f2-b034-725a43f3a6d7
Faulting package full name:
Faulting package-relative application ID:"
Or
- Windows Task Manager shows Acrobat.exe running, but Adobe Acrobat is not visible.
- Hung instances of Adobe will appear in task manager even when adobe is opened outside of engagement
Environment
- CCH ProSystem fx Engagement
- CCH ProSystem fx Workpaper Manager
- Adobe Acrobat
- Adobe Reader
Cause
If you find the error "Faulting application name" in Event Viewer, Adobe Acrobat is crashing due to an incompatibility between the program's "Protected Mode" settings and the Engagement or Workpaper Manager plug-in for Acrobat. As stated in our system requirements, Engagement and Workpaper Manager does not support Protected Mode in Adobe.
Resolution
Continue with the article further below for 32-bit Adobe Acrobat. For 64-bit Adobe Acrobat, follow the article below.
To resolve Adobe Acrobat/Adobe Reader crashing or not opening due to Protected Mode settings, follow these steps:
- Remove the PfxEngagementx.api (for Acrobat) or PfxEngagx.api (for Reader) file from the following location:
- 64-bit Adobe: ?:\Program Files\Adobe\Acrobat XX\Acrobat\Plug_ins, where "?" is the storage drive that Adobe is installed to, and XX is the version of Adobe.
- 32-bit Adobe: ?:\Program Files (x86)\Adobe\Acrobat XX\Acrobat\Plug_ins, where "?" is the storage drive that Adobe is installed to, and XX is the version of Adobe.
- Turn off protected mode in Adobe. For steps, please refer to the following Adobe articles below.
- Protected View Feature for PDFs
- When working in a terminal server environment or if you wish to push the setting, please reference Adobe's documentation below.
- The above documentation lists examples for Acrobat 10. The same key works for DC simply replace 10.0 with DC.
- Adobe > Edit > Preferences > Security (Enhanced).
- Under "Sandbox Protections" > uncheck "Enable Protected Mode" at Startup (preview).
- Under "Enhanced Security" > uncheck "Enable Enhanced Security."
- Protected View Feature for PDFs
- Only for 32-bit, replace the PfxEngagementx.api or PfxEngagx.api.
Additional Information
N/A
Solution Id | 000238236/000238236 |
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