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CCH® ProSystem fx® Knowledge Coach
Welcome to 2017 Knowledge-Based AuditsTM of HUD Multifamily Housing Programs for Knowledge Coach
This Release Notes document provides important information about the 2017 release of Knowledge Based AuditsTM of HUD Multifamily
Housing Programs. Please review this information carefully. If you have any questions, additional information is available on CCH Support
Online.

New in this Release
Knowledge-Based Audits of HUD Multifamily Housing Programs
2017 Knowledge Based Audits of HUD Multifamily Housing Programs can be installed on CCH® ProSystem fx® Engagement v7.5 by first
installing the CCH ProSystem fx Engagement v7.5 and Knowledge Coach v2.5 August Update. This update will allow users to work on the
2017 HUD Multifamily Housing Programs title without installing ProSystem fx Engagement v2017.1.3 until your firm plans to update.
This title is designed to help the auditor efficiently and effectively perform audits of housing and urban development programs in
accordance with auditing standards generally accepted in the United States of America (U.S. GAAS), Government Auditing Standards
(GAGAS), and the Consolidated Audit Guide to Audits of HUD Programs, published by the U.S. Department of Housing and Urban
Development (HUD Audit Guide). The Knowledge-Based Audit methodology is also designed to help the auditor efficiently and effectively
perform cost certification audits in accordance with attestation standards generally accepted in the United States of America, GAGAS, and
the HUD Audit Guide. HUD audits include both an audit of the financial statements and a compliance audit. The knowledge-based audit,
including the compliance audit, is a risk-based methodology that emphasizes using knowledge of the entity to make risk assessments in
connection with the financial statement and compliance audit of a HUD program. This allows the auditor to more appropriately focus audit
efforts on those areas which in the auditor’s judgment are the most significant and pose the most risk to the audit. The administration of
HUD programs includes both financial statement and compliance considerations, and requires specialized accounting and auditing
knowledge. This module includes up-to-date guidance for audits of programs identified under Chapter 3, HUD Multifamily Housing
Programs.
Conducting audits of HUD programs requires the exercise of the auditor’s professional judgment and knowledge of the requirements of the
HUD Audit Guide. This document is published for the purpose of communicating, to users of the toolset, updates and enhancements
included in the current version. This document is not, and should not be used as an audit program to update the audit documentation of an
engagement started in a previous version of this product.
This document is published for the purpose of communicating the updates and enhancements included in the current version to users of
the toolset. This document is not, and should not be used as an audit program to update the audit documentation of an engagement
started in a previous version of this product.
If you are updating from a previous version of this title, refer to the Knowledge Coach User Guide Chapter 12. The guide is found on the
Engagement File Room Help menu.
The 2017 documents include CCH® Accounting Research® material links to specific guidance that provides instant access to detailed analysis
related to the steps and processes discussed in the workpapers.

2017 Edition of Knowledge-Based Audits of HUD Multifamily Housing Programs
This edition features numerous enhancements, including:
•

Removing and adding columns to KBA-103 and KBA-103C, Evaluation and Communicating Internal Control Deficiencies Table in the
HUD Financial Statement and HUD Compliance package, respectively. These new columns make it easier to evaluate and classify
control deficiencies.

•

Adding table, “Communication of Internal Control Deficiencies” in KBA-103. This table is added to allow the auditor to document
the auditor’s communication of internal control deficiencies to those charged with governance and management. If a deficiency in
Table 1 is a material weakness, significant deficiency, or a deficiency in internal control, it will flow to this new table.

•

Reorganizing and rewording columns in Table 2 and 3 of KBA-400 and moving the column to describe the control deficiency to the
end for better documentation flow. If you select “No” in the following columns, your control deficiency documented in the last
column will flow to KBA-103:

•

–

Are Controls Activities Present

–

Effectively Designed and Implemented

–

Do Compensating Controls, If Any, Adequately Reduce the Risks of Material Misstatement

–

Are Control Activities Functioning

Reorganizing and rewording columns in Relevant Principles and Points of Focus table of KBA-401 and KBA-415 in the HUD Financial
Statement and HUD Compliance package, respectively, and moving the column to describe the control deficiency to the end for
better documentation flow. If you select “No” in the following columns, your control deficiency documented in the last column will
flow to the conclusion section:
–

Are the Relevant Principles or Points of Focus Present

–

Are the Identified Controls Effectively Designed and Implemented

–

Do Compensating Controls Adequately Reduce the Risks of Material Misstatement

–

Are the Relevant Principles Functioning for this Component of Internal Control

•

In KBA-401 and KBA-415 in the HUD Financial Statement and HUD Compliance package, respectively, adding an “N/A” option to the
“Are the Relevant Principles of Points of Focus Present?” column to the “Points of Focus” rows only. The user could document the
points of focus as not applicable, and the user will not respond to any other columns for that particular row as the diagnostics will
clear. The user should focus on the functioning of the relevant principles as not all of the points of focus are required or applicable.

•

Removing user options in the “System Change Controls” column of the “Less Complex IT Structure” table.

•

Reorganizing and rewording columns in the “More Complex IT Structure” table of KBA-402, and moving the column to describe the
control deficiency to the end for better documentation flow. If you select “No” in the following columns, your control deficiency
documented in the last column will flow to the conclusion section:
–

Are Controls Activities Present

–

Effectively Designed and Implemented

–

Do Compensating Controls, if any, Adequately Reduce the Risks of Material Misstatement

–

Are Control Activities Functioning
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•

Reorganizing and rewording columns in the “Activity-Level Control Objective” table of KBA-40X series, and moving the column to
describe the control deficiency near the end for better documentation flow.
–

–

If you select “No” in the following columns, your control deficiency documented will flow to the conclusion section:
▪

Are Controls Designed Effectively

▪

Are Key Controls Implemented

▪

Do Compensating Controls Adequately Reduce the Risks of Material Misstatement Created by the Deficiency

▪

Are Control Activities Functioning

Also, if you select “Partially” in column, Are Controls Designed Effectively, the control deficiency documented will flow to the
conclusion section.

•

Adding the functionality to allow users to insert custom rows anywhere in the subprocess table in KBA-40X series.

•

Adding appropriate “Segregation of Duties” control objectives to the KBA-40X Series.

•

Removing flow in AID-601 on steps 9, 10, and 11 that flow to KBA-102. Flow will remain on other steps in this workpaper.

•

Adding “We incorporated an element of unpredictability in designing further audit procedures as follows: (Describe) (See example
in practice point above)” to “Management Override” Financial Statement Level Risk in the Planned Overall Response column of
KBA-502.

•

Adding new KCO-003 Answer Effects for the Engagement-Level Tailoring Questions Workpaper that will show all answer effects of
each tailoring question in AUD-100.

•

Adding rounding columns in KBA-301 word version to match the Microsoft® Excel® versions of these workpapers.

•

Adding two new columns in AID-201, Section I: Nature of Nonattest Services Provided table for user to document the firm and client
personnel overseeing the nonattest services.

•

Removing steps in AUD-201 that are duplicated in AUD-101 and moving one step from AUD-201 to AUD-101.

•

Adding a "Maximum" and “Slightly Below Maximum” option in AUD-701, planned control reliance column.

•

Reorganizing and adding steps and tables in AUD-9023 to accommodate new accounting standard SAS-132.

•

Adding many new CORs, RPTs, and RESs as follows:
o

COR-910 Third-Party Support Letter

o

COR-911 Request for Confirmation from Supporting Parties of Intent and Ability to Provide Financial Support

o

RPT-0903A HUD Audit Unmodified Opinion: Emphasis-of-Matter Paragraph Related to Going-Concern Uncertainty with
Opinion on Supplementary Information (In Accordance with SAS-132)

o

RES-025 Variable Interest Entity Checklist

o

RES-026 Going Concern Checklist

Click here for the 2017 Audits of HUD Multifamily Housing Programs Title Overview for Knowledge Coach Users.

3

In addition, forms and practice aids throughout have been updated to include new examples and tips, and where applicable, to take into
account:
New literature, standards, and developments, reflected in the following current audit and accounting guidance:
•

SAS-132, The Auditor’s Consideration of an Entity’s Ability to Continue as a Going Concern

•

Revised AICPA Code of Professional Conduct (Code) including ET Section 1.295, Nonattest Services

•

FASB Accounting Standards Codification™ as of September 30, 2017, through Accounting Standards Update No. 2017-13

Important Notes:
•

Make sure to save changes to workpapers before closing the workpaper or the binder to ensure data is correctly updated.

•

If your Current Editor Knowledge Coach Microsoft® Word workpapers become read-only or crash, please do the following:

•

•

–

Keep the binder with the affected workpapers open.

–

Highlight the workpaper in the binder window and go to Tools > Save Knowledge Coach Answers.

System Requirements - This title requires the 2017 Financial Statement Base Title and the 2017 Compliance Audits Base Title. The
2017 Financial Statement Base title and the 2017 Compliance Audit Base title MUST be installed with one of the following versions
of CCH® ProSystem fx ® Engagement and Knowledge Coach.
–

Engagement v7.5.100.1223 and Knowledge Coach v2.5.100.1224 available through the CCH ProSystem fx Engagement v7.5
and Knowledge Coach v2.5 August Update. To identify what version you are running, please go to the Help > About window
within the application.

–

Engagement and Knowledge Coach v2017.1.3 or later.

A minimum of 4GB of RAM is required for optimal performance when opening and navigating through Knowledge Coach
workpapers.

License Requirements
This title requires the Knowledge-Based Audits of HUD Multifamily Housing Programs license.
Any user that does not have a license for this title will not be able to use Knowledge Coach functionality in workpapers.
For more information on how to update your licensing, view How do I add or update CCH ProSystem fx Engagement Licenses? on our
website.
For more information on how to assign licenses, view How do I assign Engagement Licenses? on our website.

Download Instructions
If you are planning to use this title on Engagement v7.5 and Knowledge Coach v2.5, ensure you apply ProSystem fx Engagement v7.5 and
Knowledge Coach v2.5 August Update to all machines including Admin servers and terminal servers before installing the title. Review the
August Update release notes for more information on deployment.
To download this title:

1.

Navigate to the Knowledge Coach Updates section of the Engagement Support Website.

2.

Select the Knowledge Coach Series. The series are arranged by title type, then industry.
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3.

Click on the Download File link next to the title you wish to download.

Note: On some occasions the content package file (.KCP) will download with the extension changed to .ZIP. If this occurs, please change the
extension of the downloaded file to KCP using all capital letters.
You must install the 2017 Financial Statement Base title and the 2017 Compliance Audit Base title before installing the 2017 Knowledge
Based Audits of HUD Multifamily Housing Programs.
The Financial Statement and Compliance Audit Base titles are also available on the Knowledge Coach Update Website.
The Knowledge Coach Content Package (KCP) download is a proprietary file that must be installed from within Engagement. Save this KCP
file to a location on your local drive, and follow the Installation Instructions included in the Release Bulletin.

Installation Instructions
Once you have downloaded your Knowledge Coach title, you will need to add it to the list of titles within CCH ProSystem fx Engagement.
The only additional system requirement is approximately 75MB of disk space to store your Knowledge Coach Program content files. Please
refer to the Engagement with Knowledge Coach Release Notes for any other system requirements.
After downloading the 2017 Knowledge Based Audits of HUD Multifamily Housing Programs, do the following:

1.

Launch the Engagement Workpaper Management application so that the Local File Room is displayed. Select Tools > Knowledge
Coach Titles.

2.

The Knowledge Coach Titles window will be displayed.

3.

Choose Add Title.

4.

Browse to the title package file (*.KCP) that you previously downloaded from the Knowledge Coach Support Web site.

5.

Choose Open.

6.

The system will display a progress indicator while the title package is added. You will receive a message that the title has been
successfully installed once the process is complete.

To release a title:

1.

Select one of the Knowledge Coach titles in the list that has been added but is not yet released.

2.

Choose Release Title. The current date and time will be displayed in the Date released column, and the status will change to
“Released.”

Note: In the Engagement Admin module, add and assign a Knowledge Coach module and the applicable Knowledge Coach title license to
staff before using the workpapers.
Important: Once the 2017 Knowledge-Based Audits of the HUD Multifamily Housing Programs title has been added and released, they will
be automatically deployed to other staff members when they login to the “Office” location, or when they synchronize a binder that
contains Knowledge Coach workpapers from this title.

Online Permission Key
Permission key files may be downloaded from our website or when adding or updating the new licenses within CCH ProSystem fx
Engagement with Knowledge Coach v7.5 and higher. After updating the license file in the Engagement Admin module, licenses need to be
assigned to the staff who will use 2017 Knowledge-Based Audits of HUD Multifamily Housing Programs.
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If you have not already established a Single Sign-on (SSO) account with Customer Service, we urge you to do so at this time.

CCH® Accounting Research Manager®
CCH’s Accounting Research Manager (ARM) is the most comprehensive, up-to-date and objective online database of financial reporting
literature. It includes all authoritative and proposed accounting, auditing, and SEC literature, plus independent, expert-written interpretive
guidance.
Available on ARM, the Knowledge-Based Audits of HUD Multifamily Housing Programs Guide helps you comply with the most recent
professional standards and guidance for the conduct of audits of HUD Multifamily Housing Programs and to integrate the use of practice
aids, tools, and other resources with its guidance. This publication supplements and complements the Knowledge-Based documents that
are available in Knowledge Coach.
If you subscribe to an ARM library that includes HUD Multifamily Housing Programs content, you can link directly to source material from
Resources within Knowledge Coach documents. These links have been updated to refer to the accounting standards under the FASB
Accounting Standards Codifications. Also, if you subscribe to the Knowledge-Based Audits of HUD Multifamily Housing Programs Guide on
ARM, you can take advantage of references to the guide material from within the Knowledge Coach documents.
With Accounting Research Manager, you maximize the efficiency of your research time, while enhancing your results. Learn more about our
content, our experts, and how you can request your free trial by visiting the Accounting Research Manager website. You can also access the
Accounting Research Manager Web site by selecting Engagement > Binder Window > Shortcuts Bar > Guidance tab.

Using Your Knowledge Coach Content
To use your Knowledge Coach Workpaper Templates, do the following:

1.

Open a binder in Engagement.

2.

Select the workpaper tab into which you would like to insert the workpaper.

3.

Select New Knowledge Coach Workpaper from the toolbar or File menu.

4.

The New Knowledge Coach Workpaper dialog appears (Figure 1).

5.

Select the New Knowledge Coach Title with the content you would like to use. You can only select titles you have installed. The
information displayed changes to reflect the workpaper organization available for the selected title.

6.

Select the Knowledge Coach Workpapers to insert into your binder and click OK.

7.

In the Selected Workpaper Properties dialog, each workpaper name is automatically loaded into the Name field. Add a workpaper
index in the Index field and make any Name modifications you desire. You can also modify the tab location or the roll forward
settings for each workpaper.

8.

Click OK. The integrated Knowledge Coach workpaper is now inserted into your engagement binder.

Note: For more information on how to use Knowledge Coach workpapers in your binder, see the Knowledge Coach User Guide.
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Figure 1 - New Knowledge Coach Workpaper

Additional Information on Knowledge Coach and the KBA Methodology
Knowledge-Based Audit (KBA) Methodology
Allows the results of one set of procedures to become the input for the next. The key components of the KBA methodology include:
•

An Overview that guides auditors through the methodology;

•

Knowledge-Based Audit documents, integral to the risk assessment and overall audit processes, which contain steps and
procedures required by U.S. GAAS, GAGAS, and the HUD Audit Guide;
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•

Customizable Audit Programs that take auditors through related steps and procedures;

•

Practice Aids to help auditors complete steps or processes outlined in the Knowledge-Based Audit documents and Audit Programs;

•

Auditor’s Reports that provide a variety of sample auditor’s opinions on audited financial statements; and

•

Correspondence documents that provide sample letters to be used to comply with U.S. GAAS, GAGAS, and the HUD Audit Guide
requirements and in many other common situations.

•

The AICPA’s Auditing Standards Board’s (ASB) Risk Assessment Standards - The practice aids and tools in the 2017 KnowledgeBased Audits of HUD Multifamily Housing Programs are designed around the AICPA’s risk assessment and clarified standards to
assist auditors of nonpublic entities by:
–

Facilitating compliance with U.S. GAAS, GAGAS, and the HUD Audit Guide;

–

Encouraging more effective audits through tailored audit programs and comprehensive practice aids;

–

Helping auditors to focus on and respond to identified audit risks; and

–

Enhancing audit documentation.

CCH® ProSystem fx® Knowledge Coach
Knowledge Coach functionality allows auditors to use the Knowledge-Based-Audit methodology more efficiently by eliminating the need for
duplicate entry of the same information, tailoring audit documentation to each particular engagement, and documenting the link between
risks identified and procedures performed. AUD-100 Tailoring Question is a document in Knowledge Coach that presents engagement-level
questions designed to aid in tailoring the engagement documentation to fit each client. Completing the questions helps the auditor avoid
duplication and unnecessary workpapers.
Note: Before you begin your audit, please review the guidance in AUD-103 Overall Audit Program. This workpaper is intended to be your
road map through a Knowledge-Based Audit methodology. You should start your audit with AUD-100 Tailoring Question Workpaper and
AUD-103 Overall Audit Program.
•

Risks
Can be captured via the Risk Summary task pane from any Knowledge Coach workpaper by the current editor of KBA-502 Summary
of Risk Assessments. This allows the user to continuously assess risks during the engagement. Several workpapers prompt the
consideration of the presence of risks, but the Risk Summary task pane must be used to document those risks. All documented risks
flow to the Risk Summary. To ensure risks show in findings tables, make sure to check the “workpaper identified in” field of the Risk
pane.

•

Information Flow
Helps cut down on the time spent duplicating information across forms. In addition, the flow of consistent information ensures that
information and updates to information are not missed between workpapers. Drill-down functionality helps the user navigate
quickly to the source of the information, aiding in the review of the audit file.

•

Diagnostics
Help keep track of unresolved issues like unanswered questions, incomplete risks, program steps not linked to risks or relevant
assertions, missing workpaper, and more.

•

Links to Accounting Research Manager (ARM)
If you subscribe to an ARM library that includes audit content, you can link directly to source material from Resources within
Knowledge Coach workpapers. These links have been updated to reference to the accounting standards under the FASB Accounting
Standards Codifications and the auditing standards issued by the AICPA. Also, if you subscribe to the Knowledge-Based Audits of
HUD Multifamily Housing Programs Guide on ARM, you can take advantage of links to the audit guide material from within the
Knowledge Coach documents.
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•

Interpretive Guidance
It is integrated into each Knowledge Coach template through the Tips view of each new task pane. Informational features include
Practice Points, Examples, Optional Workpapers, and Resources to help auditors work more effectively and efficiently. You can also
navigate from Resources within a document or the tip pane directly to CCH’s Accounting Research Manager and industry audit
guides by simply clicking on the Reference.

Download Description:

Version:

2017 Knowledge-Based Audits of HUD Multifamily Housing Programs
Engagement v7.5 and Knowledge Coach v2.5 with Engagement v7.5 and Knowledge Coach v2.5 August
Update
OR
Engagement and Knowledge Coach v2017.1 or later
2017 Financial Statement Base and 2017 Compliance Audit Base

Release Date:

December 2017

File size:

18MB

Approx. Download Time:

42 minutes at 56 kbps

License:

Full Version

Platforms:

Windows® 7, 8.1, 10

Office:

Microsoft® Office 2013 or higher required
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