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CCH® ProSystem fx® Knowledge Coach
Welcome to 2017 Knowledge-Based AuditsTM of Single Audits for Knowledge Coach
This Release Notes document provides important information about the 2017 release of Knowledge Based AuditsTM of Single Audits. Please
review this information carefully. If you have any questions, additional information is available on CCH Support Online.

New in this Release
Knowledge-Based Audits of Single Audits
2017 Knowledge Based Audits of Single Audits can be installed on CCH® ProSystem fx® Engagement v7.5 by first installing the Engagement
v7.5 and Knowledge Coach v2.5 August Update. This update will allow users to work on the 2017 Single Audit title without installing
ProSystem fx Engagement v2017.1.3 until your firm plans to update.
This title is designed to help the auditor efficiently and effectively perform the compliance audit portion of the single audit. The
methodology has been developed to be compliant with auditing standards generally accepted in the United States of America (U.S GAAS),
Government Auditing Standards (GAGAS), and the audit requirements of 2CFR200, the Uniform Administrative Requirements, Cost
Principles, and Audit Requirements for Federal Awards, (the Uniform Guidance). The frequently asked questions released by the Council on
Financial Assistance Reform (COFAR) include information on transition provisions to the Uniform Guidance. The Uniform Guidance contains
administrative requirements and cost principles beginning December 26, 2014, for all new federal awards and funding increments
(additional funding to existing federal awards) with modified award terms and conditions that are awarded on or after that date.
Implementation of administrative and cost provisions began on December 26, 2014, and is staggered by grant award. In most cases, the
terms and conditions of the federal award should identify whether the funding increment is subject to the Uniform Guidance requirements,
or whether it will continue to be governed by the original terms and conditions of the federal award (that is, subject to the pre-Uniform
Guidance requirements). The effective date of the Uniform Guidance as it relates to a subaward (pass-through grant to a subrecipient) is
the same as the effective date of the federal award. The audit provisions of the Uniform Guidance apply to audits of fiscal years beginning
on or after December 26, 2014, and are fully implemented in this tool set. 2017 Knowledge-Based Single Audits only contains tools
referencing the Uniform Guidance. Should practitioners need tools referencing OMB Circular A-133, they should download the Tools issued
prior to calendar year 2016.
Conducting single audits requires the exercise of the auditor’s professional judgment. This document is published for the purpose of
communicating, to users of the toolset, updates and enhancements included in the current version. This document is not, and should not
be used as an audit program to update the audit documentation of an engagement started in a previous version of this product.
This document is published for the purpose of communicating the updates and enhancements included in the current version to users of
the toolset. This document is not, and should not be used as an audit program to update the audit documentation of an engagement
started in a previous version of this product.
If you are updating from a previous version of this title, refer to the Knowledge Coach User Guide Chapter 12. The guide is found on the
Engagement File Room Help menu.
The 2017 documents include CCH® Accounting Research® material links to specific guidance that provides instant access to detailed analysis
related to the steps and processes discussed in the workpapers.

2017 Edition of Knowledge-Based Audits of Single Audits
This edition features numerous enhancements, including:
•

Adding a new column and wording to header in Major Program table of KBA-101S. This will allow the user to type a shortened name
in the first column and type the whole name and/or description in the 2nd column. This will help to decrease the amount of
workpapers associated with a major program that will need to be renamed when inserted into Engagement due to the character
limit of workpaper names.

•

Removing and adding columns to KBA-104S, Evaluation of Internal Control Deficiencies Table. These new columns make it easier to
evaluate and classify control deficiencies.

•

Adding table, “Communication of Internal Control Deficiencies” in KBA-104S. This table is added to document the auditor’s
communication of internal control deficiencies to those charged with governance and management. If a deficiency in table 1 is a
material weakness, significant deficiency, or a deficiency in internal control it will flow in this new table.

•

Reorganizing and rewording columns in Relevant Principles and Points of Focus table of KBA-401S and moving the column to
describe the control deficiency to the end for better documentation flow. If you select “No” in the following columns your control
deficiency documented in the last column will flow to the conclusion section:
–

Are the Relevant Principles or Points of Focus Present

–

Are the Identified Controls Effectively Designed and Implemented

–

Do Compensating Controls Adequately Reduce the Risks of Material Misstatements

–

Are the Relevant Principles Functioning for this Component of Internal Control

•

In KBA-401S adding an “N/A” option to the “Are the Relevant Principles or Points of Focus Present?” column to the “Points of
Focus” rows ONLY. The user could document the points of focus as not applicable and the user will not respond to any other
columns for that particular row as the diagnostics will clear. The user should focus on the functioning of the relevant principles as
not all of the points of focus are required or applicable.

•

Reorganizing and rewording columns in the “Control Objective” table of KBA-40XS series and moving the column to describe the
control deficiency near the end for better documentation flow.
–

–

If you select “No” in the following columns, your control deficiency documented will flow to the conclusion section:
▪

Are Controls Designed Effectively

▪

Are Key Controls Implemented

▪

Do Compensating Controls Adequately Reduce the Risks of Noncompliance Created by the Deficiency

▪

Are Control Activities Functioning

Also, if you select “Partially” in column, Are Controls Designed Effectively, the control deficiency documented will flow to the
conclusion section.

•

Removing user options in the “System Change Controls” column of the “Less Complex IT Structure” table in AID-401S.

•

Reorganizing and rewording columns in the “More Complex IT Structure” table of AID-401S and moving the column to describe the
control deficiency to the end for better documentation flow. If you select “No” in the following columns your control deficiency
documented in the last column will flow to the conclusion section:
–

Are Control Activities Present

–

Effectively Designed and Implemented

–

Do Compensating Controls, If Any, Adequately Reduce the Risks of Material Noncompliance
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–

Are Controls Functioning

•

Adding the functionality to allow users to insert custom rows anywhere in the subprocess table in KBA-40XS series.

•

Removing flow in AID-601 on steps 9, 10, and 11 that flow to KBA-102S. Flow will remain on other steps in this workpaper.

•

Adding “Planned response must incorporate an element of unpredictability in designing further audit procedures (describe)” to
“Management Override of Internal Controls” Financial Statement Level Risk in the Planned Overall Response column of KBA-502S.
This can be edited in the risk pane but remember to document the planned overall response in the risk pane as well.

•

Many new and updated Tailoring Questions and procedural steps in AID-903S to more closely align with the AICPA’s Guide to
Government Auditing Standards and Single Audits.

•

Adding new KCO-003 Answer Effects for the Engagement-Level Tailoring Questions Workpaper that will show all answer effects of
each tailoring question in AUD-100S.

•

Adding two new columns in AID-201S, Section I: Nature of Nonattest Services Provided table for user to document the firm and
client personnel overseeing the nonattest services.

•

Adding new RPT-0904AS Report on Compliance for Each Major Federal Program and Report on Internal Control over Compliance in
Accordance with the Uniform Guidance (Unmodified Opinion on Compliance for Each Major Federal Program; Material Weakness in
Internal Control over Compliance Identified, No Significant Deficiencies in Internal Control over Compliance Identified)

Click here for the 2017 Single Audit Title Overview for Knowledge Coach Users.
In addition, forms and practice aids throughout have been updated to include new examples and tips, and where applicable, to take into
account:
New literature, standards, and developments, reflected in the following current audit and accounting guidance:
•

Statement on Auditing Standards (SAS) No. 132, The Auditor’s Consideration of an Entity’s Ability to Continue as a Going Concern;

•

Government Auditing Standards;

•

AICPA Code of Professional Conduct (Code); ET Section 1.295, Nonattest Services;

•

2017 OMB Compliance Supplement;

•

2CFR200, the Uniform Administrative Requirements, Cost Principles, and Audit Requirements for Federal Awards, (the Uniform
Guidance);

•

AU-C Section 935, Compliance Audits;

•

Committee of Sponsoring Organizations (COSO) 2013 update to Internal Control —Integrated Framework

•

Government Auditing Standards, December 2011 Revision (Yellow Book).

Important Notes:
•

Make sure to save changes to workpapers before closing the workpaper or the binder to ensure data is correctly updated.

•

If your Current Editor Knowledge Coach Microsoft® Word workpapers become read-only or crash, please do the following:
–

Keep the binder with the affected workpapers open.

–

Highlight the workpaper in the binder window and go to Tools > Save Knowledge Coach Answers.

System Requirements
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•

•

This title requires the 2017 Compliance Base Title. The 2017 Compliance Base title MUST be installed with one of the following
versions of CCH® ProSystem fx ® Engagement and Knowledge Coach.
–

Engagement v7.5.100.1223 and Knowledge Coach v2.5.100.1224 available through the ProSystem fx Engagement v7.5 and
Knowledge Coach v2.5 August Update. To identify what version you are running, please go to the Help > About window
within the application.

–

Engagement and Knowledge Coach v2017.1.3 or later.

A minimum of 4GB of RAM is required for optimal performance when opening and navigating through Knowledge Coach
workpapers.

License Requirements
This title requires the Knowledge-Based Audits of Single Audits Title license.
Any user that does not have a license for this title will not be able to use Knowledge Coach functionality in workpapers.
For more information on how to update your licensing, view How do I add or update CCH ProSystem fx Engagement Licenses? on our
website.
For more information on how to assign licenses, view How do I assign Engagement Licenses? on our website.

Download Instructions
If you are planning to use this title on Engagement v7.5 and Knowledge Coach v2.5, ensure you apply ProSystem fx Engagement v7.5 and
Knowledge Coach v2.5 August Update to all machines including Admin servers and terminal servers before installing the title. Review the
August Update release notes for more information on deployment.
To download this title:

1.

Navigate to the Knowledge Coach Updates section of the Engagement Support Website.

2.

Select the Knowledge Coach Series. The series are arranged by title type, then industry.

3.

Click on the Download File link next to the title you wish to download.

Note: On some occasions the content package file (.KCP) will download with the extension changed to .ZIP. If this occurs, please change the
extension of the downloaded file to KCP using all capital letters.
You must install the 2017 Compliance Base title before installing the 2017 Knowledge Based Single Audit Title.
The Compliance Base title is also available on the Knowledge Coach Update Website.
The Knowledge Coach Content Package (KCP) download is a proprietary file that must be installed from within Engagement. Save this KCP
file to a location on your local drive, and follow the Installation Instructions included in the Release Bulletin.

Installation Instructions
Once you have downloaded your Knowledge Coach title, you will need to add it to the list of titles within CCH ProSystem fx Engagement.
The only additional system requirement is approximately 75MB of disk space to store your Knowledge Coach Program content files. Please
refer to the Engagement with Knowledge Coach Release Notes for any other system requirements.
After downloading the 2017 Knowledge Based Single Audit, do the following:
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1.

Launch the Engagement Workpaper Management application so that the Local File Room is displayed. Select Tools > Knowledge
Coach Titles.

2.

The Knowledge Coach Titles window will be displayed.

3.

Choose Add Title.

4.

Browse to the title package file (*.KCP) that you previously downloaded from the Knowledge Coach Support Web site.

5.

Choose Open.

6.

The system will display a progress indicator while the title package is added. You will receive a message that the title has been
successfully installed once the process is complete.

To release a title:

1.

Select one of the Knowledge Coach titles in the list that has been added but is not yet released.

2.

Choose Release Title. The current date and time will be displayed in the Date released column, and the status will change to
“Released.”

Note: In the Engagement Admin module, add and assign a Knowledge Coach module and the applicable Knowledge Coach title license to
staff before using the workpapers.
Important: Once the 2017 Knowledge-Based Single Audit title has been added and released, they will be automatically deployed to other
staff members when they login to the “Office” location, or when they synchronize a binder that contains Knowledge Coach workpapers
from this title.

Online Permission Key
Permission key files may be downloaded from our website or when adding or updating the new licenses within CCH ProSystem fx
Engagement with Knowledge Coach v7.5 and higher. After updating the license file in the Engagement Admin module, licenses need to be
assigned to the staff who will use 2017 Knowledge-Based Single Audit.
If you have not already established a Single Sign-on (SSO) account with Customer Service, we urge you to do so at this time.

CCH® Accounting Research Manager®
CCH’s Accounting Research Manager (ARM) is the most comprehensive, up-to-date and objective online database of financial reporting
literature. It includes all authoritative and proposed accounting, auditing, and SEC literature, plus independent, expert-written interpretive
guidance.
Available on ARM, the Knowledge-Based Single Audit Guide helps you comply with the most recent professional standards and guidance for
the conduct single audits and to integrate the use of practice aids, tools, and other resources with its guidance. This publication
supplements and complements the Knowledge-Based documents that are available in Knowledge Coach.
If you subscribe to an ARM library that includes Single Audit content, you can link directly to source material from Resources within
Knowledge Coach documents. These links have been updated to refer to the accounting standards under the FASB Accounting Standards
Codifications. Also, if you subscribe to the Knowledge-Based Single Audit Guide on ARM, you can take advantage of references to the guide
material from within the Knowledge Coach documents.
With Accounting Research Manager, you maximize the efficiency of your research time, while enhancing your results. Learn more about our
content, our experts, and how you can request your free trial by visiting the Accounting Research Manager website. You can also access the
Accounting Research Manager Web site by selecting Engagement > Binder Window > Shortcuts Bar > Guidance tab.
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Using Your Knowledge Coach Content
To use your Knowledge Coach Workpaper Templates, do the following:

1.

Open a binder in Engagement.

2.

Select the workpaper tab into which you would like to insert the workpaper.

3.

Select New Knowledge Coach Workpaper from the toolbar or File menu.

4.

The New Knowledge Coach Workpaper dialog appears (Figure 1).

5.

Select the New Knowledge Coach Title with the content you would like to use. You can only select titles you have installed. The
information displayed changes to reflect the workpaper organization available for the selected title.

6.

Select the Knowledge Coach Workpapers to insert into your binder and click OK.

7.

In the Selected Workpaper Properties dialog, each workpaper name is automatically loaded into the Name field. Add a workpaper
index in the Index field and make any Name modifications you desire. You can also modify the tab location or the roll forward
settings for each workpaper.

8.

Click OK. The integrated Knowledge Coach workpaper is now inserted into your engagement binder.

Note: For more information on how to use Knowledge Coach workpapers in your binder, see the Knowledge Coach User Guide.

Figure 1 - New Knowledge Coach Workpaper
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Additional Information on Knowledge Coach and the KBA Methodology
Knowledge-Based Audit (KBA) Methodology
Allows the results of one set of procedures to become the input for the next. The key components of the KBA methodology include:
•

An Overview that guides auditors through the methodology (for single audits, auditors can refer to the applicable Overview in
Knowledge-Based Audits of Governmental Entities or Knowledge-Based Audits of Not-for-Profit Entities);

•

Knowledge-Based Audit documents, integral to the risk assessment and overall audit processes, which contain steps and
procedures required by U.S. GAAS, GAGAS, the OMB Compliance Supplement and the Uniform Guidance;

•

Customizable Audit Programs that take auditors through related steps and procedures;

•

Practice Aids to help auditors complete steps or processes outlined in the Knowledge-Based Audit documents and Audit Programs;

•

Auditor’s Reports that provide a variety of sample auditor’s opinions on audited financial statements and the accompanying
internal control and compliance reports required by GAGAS, the OMB Compliance Supplement and the Uniform Guidance; and

•

Correspondence documents that provide sample letters to be used to comply with U.S. GAAS, GAGAS, the OMB Compliance
Supplement and the Uniform Guidance requirements and in many other common situations.

•

The AICPA’s Auditing Standards Board’s (ASB) Risk Assessment Standards, AU-C Section 935, Compliance Audits and the Uniform
Guidance - The practice aids and tools in the 2017 Knowledge-Based Single Audits are designed around the AICPA’s risk
assessment and clarified standards to assist auditors of single audits by:
–

Facilitating compliance with GAAS and GAGAS, the OMB Compliance Supplement and the Uniform Guidance;

–

Encouraging more effective audits through tailored audit programs and comprehensive practice aids;

–

Helping auditors to focus on and respond to identified audit risks; and

–

Enhancing audit documentation.

CCH® ProSystem fx® Knowledge Coach
Knowledge Coach functionality allows auditors to use the Knowledge-Based-Audit methodology more efficiently by eliminating the need for
duplicate entry of the same information, tailoring audit documentation to each particular engagement, and documenting the link between
risks identified and procedures performed. AUD-100S Tailoring Question is a document in Knowledge Coach that presents engagementlevel questions designed to aid in tailoring the engagement documentation to fit each client. Completing the questions helps the auditor
avoid duplication and unnecessary workpapers.
Note: Before you begin your audit, please review the guidance in AUD-101S Overall Audit Program: Uniform Guidance Audit of Federal
Awards. This workpaper is intended to be your road map through a Knowledge-Based Audit methodology. You should start your audit with
AUD-100S Tailoring Question Workpaper and AUD-101S Overall Audit Program.
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•

Risks
Can be captured via the Risk Summary task pane from any Knowledge Coach workpaper by the current editor of KBA-502S
Summary of Risk Assessments of Risks of Noncompliance. This allows the user to continuously assess risks during the engagement.
Several workpapers prompt the consideration of the presence of risks, but the Risk Summary task pane must be used to document
those risks. All documented risks flow to the Risk Summary. To ensure risks show in findings tables, make sure to check the
“workpaper identified in” field of the Risk pane.

•

Information Flow
Helps cut down on the time spent duplicating information across forms. In addition, the flow of consistent information ensures that
information and updates to information are not missed between workpapers. Drill-down functionality helps the user navigate
quickly to the source of the information, aiding in the review of the audit file.

•

Diagnostics
Help keep track of unresolved issues like unanswered questions, incomplete risks, program steps not linked to risks or relevant
assertions, missing workpaper, and more.

•

Links to Accounting Research Manager (ARM)
If you subscribe to an ARM library that includes audit content, you can link directly to source material from Resources within
Knowledge Coach workpapers. These links have been updated to reference to the accounting standards under the FASB and GASB
Accounting Standards Codifications and the auditing standards issued by the AICPA and the U.S. Government Accountability Office
(GAO). Also, if you subscribe to the Knowledge-Based Single Audit Guide on ARM, you can take advantage of links to the audit guide
material from within the Knowledge Coach documents.

•

Interpretive Guidance
It is integrated into each Knowledge Coach template through the Tips view of each new task pane. Informational features include
Practice Points, Examples, Optional Workpapers, and Resources to help auditors work more effectively and efficiently. You can also
navigate from Resources within a document or the tip pane directly to CCH’s Accounting Research Manager and industry audit
guides by simply clicking on the Reference.

Download Description:

Version:

2017 Knowledge-Based Single Audits (10/19/2017)
Engagement v7.5 and Knowledge Coach v2.5 with Engagement v7.5 and Knowledge Coach v2.5 August
Update
OR
Engagement and Knowledge Coach v2017.1 or later
2017 Compliance Base

Release Date:

October 2017

File size:

18MB

Approx. Download Time:

42 minutes at 56 kbps

License:

Full Version

Platforms:

Windows® 7, 8.1, 10

Office:

Microsoft® Office 2013 or higher required

8

