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CCH® ProSystem fx® Knowledge Coach
Welcome to 2018 Knowledge-Based Examinations of Service Organizations for Knowledge Coach
This Release Notes document provides important information about the 2018 release of Knowledge Based Examinations of Service
Organizations. Please review this information carefully. If you have any questions, additional information is available on CCH Support
Online.

New in this Release
Knowledge-Based™ Examinations of Service Organizations
2018 Knowledge Based Examinations of Service Organizations can be installed on CCH® ProSystem fx® Engagement v7.5 by first installing
the CCH ProSystem fx Engagement v7.5 and Knowledge Coach v2.5 August Update. The latest update can be downloaded here. This update
will allow users to work on the 2018 Examinations of Service Organizations title without installing ProSystem fx Engagement v2017.1.3 until
your firm plans to update.
This title is designed to help the practitioner efficiently and effectively conduct examination engagements of service organizations in
accordance with applicable standards issued by the American Institute of Certified Public Accountants (AICPA). The knowledge-based
methodology for service organization engagements is a risk-based methodology for conducting examination engagements of service
organizations. It emphasizes using knowledge of the entity, subject matter, and criteria to make the risk assessments and recommendations
in connection with an engagement. The more accurately a practitioner assesses risks of material misstatement or deviation, the more
assurance the practitioner has that the procedures performed in response to the risk assessments will detect material misstatements or
deviations.
Examination of Service Organizations are often unique and complex, and require specialized accounting, and attestation knowledge.
Conducting Examination of Service Organizations requires the exercise of the practitioner’s professional judgment. This edition includes
specific up-to-date guidance for Examination of Service Organizations and is published for the purpose of communicating, to users of the
toolset, updates and enhancements included in the current version. This document is not, and should not be used as an engagement
program to update the documentation of an engagement started in a previous version of this product.
The forms and practice aids in the knowledge-based methodology will help the practitioner to perform the procedures necessary to
complete the engagement in accordance with professional standards. The Knowledge-Based tools include documents, attestation
programs, practice aids, correspondence, and example reports.
Although the KBA approach provides a framework for applying attestation standards, it is not a substitute for knowledge of professional
standards and the exercise of the practitioner’s professional judgment and professional skepticism. The practitioner may need to refer to
additional resources to determine how to apply the applicable standards to unfamiliar or unique circumstances.
This document is published for the purpose of communicating the updates and enhancements included in the current version to users of
the toolset. This document is not, and should not be used as an audit program to update the audit documentation of an engagement
started in a previous version of this product.
If you are updating from a previous version of this title, refer to the Knowledge Coach User Guide Chapter 12. The guide is found on the
Engagement File Room Help menu.

The 2018 documents include CCH® Accounting Research® material links to specific guidance that provides instant access to detailed analysis
related to the steps and processes discussed in the workpapers.
2018 Edition of Knowledge-Based Examinations of Service Organizations
This edition features numerous enhancements, including:
•

Removing Tailoring Question, “Do we intend to test the operating effectiveness of controls?” and all show/hide related to this TQ.

•

Reorganizing ATT-101, ATT-114 and ATT-115 so that procedures common to all examinations of service organizations are now
included in ATT-101. This helps eliminate duplicative steps.

•

Updating ATT-114 and ATT-115 to now include specific steps to SOC 1 and SOC 2/SOC 3 engagement, respectively.

•

Adding ATT-301 Understanding the Subject Matter to aid the practitioner in identifying and documenting pertinent facts about the
subject matter to be used in further risk assessment procedures.

•

Reorganizing and rewording columns in Relevant Principles and Points of Focus table of ATT-401 and moving the column to describe
the control deficiency to the end for better documentation flow.
If you select “No” in the following columns, your control deficiency documented in the last column will flow to the conclusion
section:
–

Are the Relevant Principles or Points of Focus Present?

–

Are the Identified Controls Effectively Designed and Implemented?

–

Do Compensating Controls Adequately Reduce the Risks of Material Misstatement?

–

Are the Relevant Principles Functioning for this Component of Internal Control?

•

In ATT-401, adding an “N/A” option to the “Are the Relevant Principles of Points of Focus Present?” column to the “Points of Focus”
rows only. The user could document the points of focus as not applicable and the user will not respond to any other columns for
that particular row as the diagnostics will clear. The user should focus on the functioning of the relevant principles as not all of the
points of focus are required or applicable.

•

Removing user options in the “System Change Controls” column of the “Less Complex IT Structure” table of ATT-402.

•

Reorganizing and rewording columns in the “More Complex IT Structure” table of KBA-402 and moving the column to describe the
control deficiency to the end for better documentation flow.
If you select “No” in the following columns, your control deficiency documented in the last column will flow to the conclusion
section:
–

Are Controls Present?

–

Effectively Designed and Implemented?

–

Do Compensating Controls Adequately Reduce the Risks of Material Misstatement?

–

Are Control Functioning?

•

New column in KBA-101 to describe communication.

•

Reorganizing KBA-201 to be more consistent with KBA Non-Traditional Engagements and to be compliant with SSAE No. 18.

•

Revising and Reorganizing KBA-501. This workpaper will reset on roll forward.

•

Adding New AID-101 Overall Examination Engagement Strategy as a foundation workpaper. This workpaper is similar to KBA-101 in
our Commercial title. This new workpaper has flow from KBA-200 and flow in for “Significant Change” tables throughout other
workpapers.
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•

Adding two new columns in AID-201, Section I: Nature of Nonattest Services Provided table for user to document the firm and client
personnel overseeing the nonattest services

•

Adding a “Maximum” and “Slightly Below Maximum” option in AID-702, planned control reliance column.

•

Adding a new flow of information from KBA-200 to KBA-501 regarding the type of reporting, subject matter, and stated criteria.

•

Moving the Inherent Risk section of KBA-502 into new workpaper KBA-503.

•

The addition of many new documents as follows:
–

KBA-301E Worksheet for Documenting Materiality Considerations

–

KBA-503 Basis for Inherent Risk Assessment

–

ATT-301 Understanding the Subject Matter

–

ATT-401N Understanding Entity-Level Controls: Noncomplex Entities

–

ATT-404 Evaluation of Management’s Description of the Service Organization’s System (SOC 2)

–

ATT-902 Attestation Program: Subsequent Events

–

AID-101 Overall Examination Engagement Strategy

–

AID-606 Involvement of an Other Practitioner

–

COR-917 Representation Letter: Type 1 or 2 Engagement to Report on Controls at a Service Organization Relevant to Security,
Availability, Processing Integrity, Confidentiality, and Privacy (SOC 2)

–

COR-918 Representation Letter: Representations from Management of the Subservice Organization, When the Service
Organization Uses the Inclusive Method

–

COR-919 Representation Letter: Engaging Party - SOC 1

–

COR-920 Representation Letter: Engaging Party - SOC 2

–

RES-018 Comparison of SOC 1, SOC 2, and SOC 3 Engagements and Related Reports

Click here for the 2018 Examination of Service Organizations Title Overview for Knowledge Coach Users.
In addition, forms and practice aids throughout have been updated to include new examples and tips, and where applicable, to take into
account:
New literature, standards, and developments, reflected in the following current audit and accounting guidance:
•

AICPA Audit and Accounting Guide, Service Organizations: Applying SSAE No. 16, Reporting on Controls at a Service Organization
Relevant to User Entities’ Internal Control Over Financial Reporting (SOC 1);

•

AICPA Audit and Accounting Guide, Reporting on Controls at a Service Organization Relevant to Security, Availability, Processing
Integrity, Confidentiality, or Privacy (SOC 2);

•

TSP section 100, Trust Services Principles, Criteria, and Illustrations for Security, Availability, Processing Integrity, Confidentiality,
and Privacy, as applicable.

•

Government Auditing Standards (GAGAS), 2011 Revision.

•

AICPA Statement on Quality Control Standards (SQCSs) No. 8, A Firm’s System of Quality Control (Redrafted) (QC Section 10).
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•

AICPA Statement on Standards for Attestation Engagements (SSAE) No. 18, Attestation Standards: Clarification and Recodification.

•

AICPA AAG, Service Organizations Reporting on Controls at a Service Organization Relevant to User Entities Internal Control over
Financial Reporting, Revised 2017 and for 2017 Trust Services Criteria.

Important Notes:
•

Make sure to save changes to workpapers before closing the workpaper or the binder to ensure data is correctly updated.

•

If your Current Editor Knowledge Coach Microsoft® Word workpapers become read-only or crash, please do the following:
–

Keep the binder with the affected workpapers open.

–

Highlight the workpaper in the binder window and go to Tools > Save Knowledge Coach Answers.

System Requirements
•

•

This title requires the 2017 Financial Statement Base Title. The 2017 Financial Statement Base title MUST be installed with one of
the following versions of CCH® ProSystem fx ® Engagement and Knowledge Coach.
–

Engagement v7.5.100.1223 and Knowledge Coach v2.5.100.1224 available through the CCH ProSystem fx Engagement v7.5
and Knowledge Coach v2.5 August Update or later. To identify what version you are running, please go to the Help > About
window within the application.

–

Engagement and Knowledge Coach v2017.1.3 or later.

A minimum of 4GB of RAM is required for optimal performance when opening and navigating through Knowledge Coach
workpapers.

License Requirements
This title requires the Knowledge-Based SOC Engagement license.
Any user that does not have a license for this title will not be able to use Knowledge Coach functionality in workpapers.
For more information on how to update your licensing, view How do I add or update CCH ProSystem fx Engagement Licenses? on our
website.
For more information on how to assign licenses, view How do I assign Engagement Licenses? on our website.

Download Instructions
If you are planning to use this title on Engagement v7.5 and Knowledge Coach v2.5, ensure you apply ProSystem fx Engagement v7.5 and
Knowledge Coach v2.5 August Update or later to all machines including Admin servers and terminal servers before installing the title.
Review the August Update release notes for more information on deployment.
To download this title:

1.

Navigate to the Knowledge Coach Updates section of the Engagement Support Website.

2.

Select the Knowledge Coach Series. The series are arranged by title type, then industry.

3.

Click on the Download File link next to the title you wish to download.

Note: On some occasions the content package file (.KCP) will download with the extension changed to .ZIP. If this occurs, please change the
extension of the downloaded file to KCP using all capital letters.
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You must install the 2017 Financial Statement Base title before installing the 2018 Knowledge Based Examination of Service Organizations.
The Financial Statement Base title is also available on the Knowledge Coach Update Website.
The Knowledge Coach Content Package (KCP) download is a proprietary file that must be installed from within Engagement. Save this KCP
file to a location on your local drive, and follow the Installation Instructions below.

Installation Instructions
Once you have downloaded your Knowledge Coach title, you will need to add it to the list of titles within CCH ProSystem fx Engagement.
The only additional system requirement is approximately 75MB of disk space to store your Knowledge Coach Program content files. Please
refer to the Engagement with Knowledge Coach Release Notes for any other system requirements.
After downloading the 2018 Knowledge Based Examination of Service Organizations, do the following:

1.

Launch the Engagement Workpaper Management application so that the Local File Room is displayed. Select Tools > Knowledge
Coach Titles.

2.

The Knowledge Coach Titles window will be displayed.

3.

Choose Add Title.

4.

Browse to the title package file (*.KCP) that you previously downloaded from the Knowledge Coach Support Web site.

5.

Choose Open.

6.

The system will display a progress indicator while the title package is added. You will receive a message that the title has been
successfully installed once the process is complete.

To release a title:

1.

Select one of the Knowledge Coach titles in the list that has been added but is not yet released.

2.

Choose Release Title. The current date and time will be displayed in the Date released column, and the status will change to
“Released.”

Note: In the Engagement Admin module, add and assign a Knowledge Coach module and the applicable Knowledge Coach title license to
staff before using the workpapers.
Important: Once the 2018 Knowledge-Based Examination of Service Organizations title has been added and released, they will be
automatically deployed to other staff members when they login to the “Office” location, or when they synchronize a binder that contains
Knowledge Coach workpapers from this title.

Online Permission Key
Permission key files may be downloaded from our website or when adding or updating the new licenses within CCH ProSystem fx
Engagement with Knowledge Coach v7.5 and higher. After updating the license file in the Engagement Admin module, licenses need to be
assigned to the staff who will use 2018 Knowledge-Based Examination of Service Organizations.
If you have not already established a Single Sign-on (SSO) account with Customer Service, we urge you to do so at this time.

5

CCH® Accounting Research Manager®
CCH’s Accounting Research Manager (ARM) is the most comprehensive, up-to-date and objective online database of financial reporting
literature. It includes all authoritative and proposed accounting, auditing, and SEC literature, plus independent, expert-written interpretive
guidance.
Available on ARM, the Knowledge-Based Examination of Service Organizations Guide helps you comply with the most recent professional
standards and guidance for the conduct of Examination of Service Organizations and to integrate the use of practice aids, tools, and other
resources with its guidance. This publication supplements and complements the Knowledge-Based documents that are available in
Knowledge Coach.
If you subscribe to an ARM library that includes Examination of Service Organizations content, you can link directly to source material from
Resources within Knowledge Coach documents. These links have been updated to refer to the accounting standards under the FASB
Accounting Standards Codifications. Also, if you subscribe to the Knowledge-Based Examination of Service Organizations Guide on ARM,
you can take advantage of references to the guide material from within the Knowledge Coach documents.
With Accounting Research Manager, you maximize the efficiency of your research time, while enhancing your results. Learn more about our
content, our experts, and how you can request your free trial by visiting the Accounting Research Manager website. You can also access the
Accounting Research Manager Web site by selecting Engagement > Binder Window > Shortcuts Bar > Guidance tab.

Using Your Knowledge Coach Content
To use your Knowledge Coach Workpaper Templates, do the following:

1.

Open a binder in Engagement.

2.

Select the workpaper tab into which you would like to insert the workpaper.

3.

Select New Knowledge Coach Workpaper from the toolbar or File menu.

4.

The New Knowledge Coach Workpaper dialog appears (Figure 1).

5.

Select the New Knowledge Coach Title with the content you would like to use. You can only select titles you have installed. The
information displayed changes to reflect the workpaper organization available for the selected title.

6.

Select the Knowledge Coach Workpapers to insert into your binder and click OK.

7.

In the Selected Workpaper Properties dialog, each workpaper name is automatically loaded into the Name field. Add a workpaper
index in the Index field and make any Name modifications you desire. You can also modify the tab location or the roll forward
settings for each workpaper.

8.

Click OK. The integrated Knowledge Coach workpaper is now inserted into your engagement binder.

Note: For more information on how to use Knowledge Coach workpapers in your binder, see the Knowledge Coach User Guide.
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Figure 1 - New Knowledge Coach Workpaper
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Additional Information on Knowledge Coach and the KBA Methodology
Knowledge-Based Audit (KBA) Methodology
Allows the results of one set of procedures to become the input for the next. The key components of the KBA methodology include:
•

An Overview that guides auditors through the methodology;

•

Knowledge-Based Attestation documents, integral to the risk assessment and overall audit processes, which contain steps and
procedures required by professional standards;

•

Customizable Engagement Programs that take auditors through related steps and procedures;

•

Practice Aids to help auditors complete steps or processes outlined in the Knowledge-Based Attestation documents and
Attestation Programs;

•

Practitioner’s Reports that provide a variety of sample practitioner’s opinions on nontraditional engagements; and

•

Correspondence documents that provide sample letters to be used to comply with professional standards, SSAE and SSCS
requirements and in many other common situations.

CCH® ProSystem fx® Knowledge Coach
Knowledge Coach functionality allows auditors to use the Knowledge-Based-Audit methodology more efficiently by eliminating the need for
duplicate entry of the same information, tailoring audit documentation to each particular engagement, and documenting the link between
risks identified and procedures performed. ATT-100 Tailoring Question is a document in Knowledge Coach that presents engagement-level
questions designed to aid in tailoring the engagement documentation to fit each client. Completing the questions helps the auditor avoid
duplication and unnecessary workpapers.
Note: Before you begin your engagement, please review the guidance in ATT-101 Overall Attestation Program. This workpaper is intended
to be your road map through a Knowledge-Based Audit methodology. You should start your audit with ATT-100 Tailoring Question
Workpaper and ATT-101 Overall Attestation Program.
•

Risks
Can be captured via the Risk Summary task pane from any Knowledge Coach workpaper by the current editor of KBA-501 Summary
of Risk Assessments. This allows the user to continuously assess risks during the engagement. Several workpapers prompt the
consideration of the presence of risks, but the Risk Summary task pane must be used to document those risks. All documented risks
flow to the Risk Summary. To ensure risks show in findings tables, make sure to check the “workpaper identified in” field of the Risk
pane.

•

Information Flow
Helps cut down on the time spent duplicating information across forms. In addition, the flow of consistent information ensures that
information and updates to information are not missed between workpapers. Drill-down functionality helps the user navigate
quickly to the source of the information, aiding in the review of the engagement file.

•

Diagnostics
Help keep track of unresolved issues like unanswered questions, incomplete risks, program steps not linked to risks or relevant
assertions, missing workpaper, and more.

•

Links to Accounting Research Manager (ARM)
If you subscribe to an ARM library that includes audit content, you can link directly to source material from Resources within
Knowledge Coach workpapers. These links have been updated to reference to the accounting standards under the FASB Accounting
Standards Codifications and the auditing standards issued by the AICPA. Also, if you subscribe to the Knowledge-Based
Examinations of Service Organizations Guide on ARM, you can take advantage of links to the audit guide material from within the
Knowledge Coach documents.

•

Interpretive Guidance
It is integrated into each Knowledge Coach template through the Tips view of each new task pane. Informational features include
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Practice Points, Examples, Optional Workpapers, and Resources to help auditors work more effectively and efficiently. You can also
navigate from Resources within a document or the tip pane directly to CCH’s Accounting Research Manager and industry audit
guides by simply clicking on the Reference.

Download Description:

Version:

2018 Knowledge-Based Examination of Service Organizations
Engagement and Knowledge Coach v2017.1 or later
OR
Engagement v7.5 and Knowledge Coach v2.5 with Engagement v7.5 and Knowledge Coach v2.5 August
Update or later
2017 Financial Statement Base

Release Date:

January 2018

File size:

18MB

Approx. Download Time:

42 minutes at 56 kbps

License:

Full Version

Platforms:

Windows® 7, 8.1, 10

Office:

Microsoft® Office 2013 or higher required
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