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Chapter 1

WELCOME TO CCH® PROSYSTEM FX®
KNOWLEDGE COACH
Chapter 1 - W el come to CCH® ProSystem fx®

Knowl edge Coach

Welcome to CCH ProSystem fx Knowledge Coach, the latest addition to the CCH suite of audit
workflow and guidance software. Developed from the ground up by auditors, for auditors, Knowledge
Coach combines the industry-specific content and guidance of CCH ProSystem fx Knowledge-Based
Audit methodology with a dynamic audit workflow engine that streamlines your audit planning
process, and helps you efficiently manage an audit from beginning to end.
Knowledge Coach is not just a planning tool, a workpaper generator or an audit workflow
management tool. It’s all of these things and more.

The Next Level of Audit Efficiency
Enable your auditors to get back to auditing with Knowledge Coach. Unfortunately, auditors are
spending more and more of their time performing administrative tasks, such as managing
workpapers, looking up information and making sure data is entered in all the necessary locations.
Knowledge Coach takes care of this, letting your auditors get back to auditing. It also provides the
following:

Impressive increases in efficiency. Knowledge Coach significantly reduces time spent on
your engagements through dynamic planning tools, flow of data throughout the application and
workpapers, and powerful roll-forward capacity.
Compliance with latest risk-based audit standards. Knowledge Coach quickly guides you
through audit planning, ensuring that your engagement is tailored to the specific entity and its
risks. It also facilitates your ongoing management of risks and program steps, ensuring that all
identified risks are addressed throughout the engagement.
Reduction in the risk and cost of over-audits. Knowledge Coach links audit procedures to
identified risks, allowing your auditors to focus on needed steps and identify unnecessary ones.
Dramatic improvements in accuracy. Extensive diagnostics ensure completeness. But with
Knowledge Coach, information that impacts more than one workpaper or step is flowed
throughout the workpapers — immediately and accurately. There is no need to find and update
affected areas manually, risking incomplete or incorrect updating.
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Total flexibility. With Knowledge Coach, your audit plans are tailored to a specific entity using
our Knowledge-Based Audit guidance, tailoring questions, and your auditor’s professional
judgment. Changes are maintained through roll-forward and content updates.
Transparency. Knowledge Coach tells your auditors what it is doing through drill-downs,
workflow links, diagnostics, and descriptions of the effects of answers on your workpapers.
5/10/2016, 3:38 PM
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Chapter 2

GETTING SET UP
Chapter 2 - Getti ng Set Up

You must complete a few administrative steps to set up your firm for Knowledge Coach. This section
covers these setup tasks.

Installation
Knowledge Coach is a module that works within the Engagement application. In Engagement version
6.0 and higher, you can choose to install the Knowledge Coach module. During the installation
process, select Knowledge Coach on the Custom Setup page of the InstallShield Wizard.
Knowledge Coach requires the use of the Microsoft ® Office 2010, 2013, 2016, or 365™ - Desktop
version platform, so you can enjoy the features of Word and Excel® to which your staff is accustomed.

Note : If you have already installed Engagement 6.0 or higher and did not originally select the
Knowledge Coach module, go to Control Panel and select to Modify the Engagement application
from the Programs group.

Ports
Engagement transfers data over the following ports:
SQL Server (PROFXENGAGEMENT) – TCP port 2029; UDP port 1434
PFXSYNPFTService - TCP port 6735
PFXEngDesktopService - TCP port 6736
PfxConfigUtility – UDP port 6737
P2EWinService - TCP ports 943 and 4530
Pfx.Engagement.SocketService - TCP port 4531
SharedFileRoom (on Vista) – TCP port 445
These ports are configured on the server and workstations during installation. However, if you are
connecting over a VPN or through a firewall, or another device such as a router, you will need to
ensure that these ports are opened in order for the program to work correctly.
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Licensing
There are three licenses involved in using Knowledge Coach workpapers:

Engagement Workpaper Management license . This license allows users to access the
Workpaper Management module of Engagement.
Knowledge Coach module license . If you have a license to the Knowledge Coach module,
you will be able to view and navigate within and between the Knowledge Coach workpapers in a
binder. You’ll also be able to perform some common reviewer tasks, such as perusing the
Program Step Library and deleting diagnostics.
Specific Knowledge-Based audit title license . Having a license to each of the KnowledgeBased Audit industry titles will allow you to fully edit the Knowledge Coach workpapers for a
particular industry title.
Contact your system administrator for assistance with the licenses that have been assigned to you.
Here is a complete list of the license combinations required to complete each function:

License Required
Function

Engagement
Workpaper
Management

Knowledge
Coach

Specific
KnowledgeBased Audit Title

Insert Knowledge Coach workpapers

X

Open Knowledge Coach workpapers

X

Add, edit, and delete risks

X

X

X

View Risk Summary

X

X

X

Answer questions within Knowledge
Coach workpapers

X

X

X

Edit various fields within Knowledge
Coach workpapers

X

X

X

Insert and delete rows and columns within
Knowledge Coach workpapers

X

X

X

View and navigate the Program Step
Library

X

X

Add and remove program steps from the
Program Step Library to an audit program

X

X

X

Add custom program steps, modify CCHprovided steps, and delete program steps

X

X

X
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License Required
Engagement
Workpaper
Management

Knowledge
Coach

Specific
KnowledgeBased Audit Title

Sign off on program steps, mark them as
"N/A," or remove sign off information

X

X

X

Use drill-down functionality between
Knowledge Coach workpapers and
diagnostics

X

X

Delete diagnostics

X

X

Insert workpapers from missing workpaper
diagnostics

X

X

Update a Knowledge Coach workpaper to
a later version

X

X

X

Override data retention options for
Knowledge Coach workpapers for binder
roll forward

X

X

X

Function

For information about adding licenses in the Engagement Administrator module and assigning
licenses to staff, see the Engagement Administrator Help file.

Staff Group Rights
Specific staff group rights are available to help your firm control which of your staff members have
access to certain functions. These staff group rights are listed as follows:

Roll Forward
Knowledge Coach – Override response roll forward setting . Allows group members to
override roll forward settings that have been applied to responses in a Knowledge Coach
workpaper.
Knowledge Coach – Accept/reject changes in updated content. Allows group members to
accept/reject changes to updated Knowledge Coach content.

Notes/Diagnostics
Delete diagnostics. Allows group members to delete a Knowledge Coach diagnostic, in the event
that it is not relevant to your engagement. For example, you may want to delete the diagnostic for
“Workpaper Missing - You have indicated potential going concern issues so you should add and
complete AUD-902 Audit Program for Consideration of Going Concern” if your firm has their own
preferred form of this documentation. Typically, reviewers should be given this staff group right.
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Sign Off
Knowledge Coach – Keep program step sign off for workpapers created from existing
workpapers. Allows group members to keep program step sign off information in Knowledge
Coach workpapers when copying and pasting binders, creating new binders, and copying and
pasting workpapers.
Delete another user's program step sign off. Allows group members to delete the program
step sign off or "NA" that was entered by another user.

Content
Add Knowledge Coach titles. Browse to downloaded title packages (*.KCP files) and add the
content for a given Knowledge Coach title to the Knowledge Coach content database on your
computer. Give this right to a person in your firm who has a CCH ProSystem fx account login,
and is responsible for retrieving titles and distributing out to the rest of the staff.
Release/unrelease Knowledge Coach titles. Releasing a Knowledge Coach title that has
been added to the database makes it available to other staff members in your firm so that they
can start adding workpapers to binders from that title. Unreleasing a title takes a title out of
circulation for the entire firm. Give this right to a person in your firm who is responsible for
managing the latest versions of titles.
Insert Knowledge Coach workpapers from unreleased titles. This right allows you to
preview Knowledge Coach workpapers from a given title by inserting them into a binder before a
title is released into general circulation in your firm. Give this right to people who review titles,
prepare binder templates, and generally prepare other staff members for work on audit
materials.
For more information on how to add or modify staff group rights, see the "Setting Up Staff Groups"
book of the Engagement Administrator Help.

Getting Title Content
Before you can start inserting Knowledge Coach workpapers in your Engagement binders, you must
download and install the Knowledge Coach industry-specific content that is compatible with the
Knowledge Coach module. Once one person in your firm downloads and releases a title, the rest of
your staff will receive the title via either the login process (when the Office location is selected) or via
the synchronization process between Local File Rooms or with the Central File Room.

Viewing Available Knowledge Coach Titles
To view the Knowledge Coach titles that are available to you, do the following:

1. Launch CCH® ProSystem fx® Engagement so that the Local File Room is displayed.
2. Select Tools > Knowledge Coach Titles.
3. The Knowledge Coach Titles window displays.
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Any Knowledge Coach titles that have been added to your system will be listed here, along with
details about the base title, when CCH released the title, the status of the title, when your firm added
the title, and when it was released to the staff at your firm. If you do not see any titles listed here, it
means that titles have not yet been added and/or released. See the following sections, Downloading
a Knowledge Coach Title below, Adding a Knowledge Coach Title below, and Releasing a
Knowledge Coach Title on the next page for more information.

Downloading a Knowledge Coach Title
To download a Knowledge Coach title, do the following:

1. At the bottom of the Knowledge Coach Titles window, click the View other available
Knowledge Coach titles available for download link to launch the Knowledge Coach
Support website, where the available Knowledge Coach title packages are listed.
2. Click the title to download. Detailed information about the title displays.
3. Scroll down to the How to install section.
4. Click Download .
5. Select a location to which you want to store the title package file, which will have a *.KCP
extension.
Notes:
You must have a CCH ProSystem fx Single Sign On (SSO) user ID and password to access the
Engagement Support Web site where the Knowledge Coach titles are stored.
Titles used on Knowledge Coach version 2.0 or later will require a Base Title to be downloaded
in addition to the Knowledge Coach Industry Title. Use the same process to download the Base
Title as you use for any other title.

Adding a Knowledge Coach Title
Once you have downloaded a Knowledge Coach title package (*.KCP file), you can add this industryspecific content to your Knowledge Coach database.
To add a title, do the following:

1. Launch CCH ProSystem fx Engagement so that the Local File Room is displayed.
2. Select Tools > Knowledge Coach Titles. The Knowledge Coach Titles window displays.
3. Click Add Title .
4. Browse to the title package file (*.KCP) that you previously downloaded from the Knowledge
Coach Support Web site. If the title you are adding is for Knowledge Coach 2.0 or later, you first
need to make sure the appropriate Base Title has been added. Then you will be able to add the
industry title package. To add the Base Title, use the same process to download and add the
Base Title as you use for any other title.
5. Click Open . A progress indicator displays while the title package is added. You will receive a
message that the title has been successfully installed once the process is complete.
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Notes:
You must have appropriate staff group rights to add a Knowledge Coach title. See Staff Group
Rights on page 5 for more information. Once the Knowledge Coach title is added to your
system, you can insert Knowledge Coach workpapers from that title, and the content for that
title will synch to other users via the Office Login process or via synchronization between Local
File Rooms or with the Central File Room. However, other users will not be able to add
workpapers from the title or update to that title until it has been released, unless a particular
staff member has the staff group right to insert Knowledge Coach workpapers from unreleased
titles. For more details, see the next section, Releasing a Knowledge Coach Title.
There may be more than one Base Title available. Information in the release bulletin and on the
Engagement Support Web site where the Knowledge Coach titles are stored will give you the
information about which Base Title is required for the industry title you want to add. You will be
able to tell if the required Base Title has already been added by viewing the Knowledge Coach
Titles window. The Base Title is indicated as "Base Title" in the Base Title column.

Releasing a Knowledge Coach Title
A Knowledge Coach title must be released in order for general users in your firm to insert Knowledge
Coach workpapers into their Engagement binders.
To release a title, do the following:

1. Launch CCH ProSystem fx Engagement so that the Local File Room is displayed.
2. Select Tools > Knowledge Coach Titles. The Knowledge Coach Titles window displays.
3. Select one of the Knowledge Coach titles in the list that has been added but is not yet released.
4. Click Release Title . The current date and time display in the Date released column, and the
status changes to Released.
Notes:
You must have appropriate staff group rights to release a Knowledge Coach title. See Staff
Group Rights on page 5 for more information. Once the Knowledge Coach title is added to your
system, you can start inserting Knowledge Coach workpapers from that title. However, other
users will not be able to add workpapers from the title or update to that title until the title has
been released, unless a particular staff member has the staff group right to insert Knowledge
Coach workpapers from unreleased titles.
The Base Title does not need to be released. Users will not insert workpapers directly from the
Base Title. See Inserting Knowledge Coach Workpapers on page 10 for more information.

Unreleasing a Knowledge Coach Title
You may decide that you want to take a particular version of a Knowledge Coach title out of circulation
in your firm so that no new Knowledge Coach workpapers will be created from it.
For example, when a new version of a Knowledge Coach title is released, you may want to take the
previous version out of circulation. By unreleasing previous versions of a title, you can ensure that your
staff will insert new workpapers from only the latest version of the title.
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To unrelease a title, do the following:

1. Launch CCH ProSystem fx Engagement so that the Local File Room is displayed.
2. Select Tools > Knowledge Coach Titles. The Knowledge Coach Titles window displays.
3. Select the Knowledge Coach title that you want to unrelease.
4. Click Unrelease Title , and then click Yes to confirm the decision. The status changes from
Released to Installed.
Note : You must have appropriate staff group rights to unrelease a Knowledge Coach title. See
Staff Group Rights on page 5 for more information.
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Chapter 3

GETTING STARTED WITH KNOWLEDGE
COACH WORKPAPERS
Chapter 3 - Getti ng Started wi th Knowl edge Coach W orkpapers

Content Used in Knowledge Coach
Knowledge Coach supports Microsoft ® Word 2010, 2013, 2016, or 365™ - Desktop version and
Microsoft ® Excel® 2010, 2013, 2016, or 365™ - Desktop version for displaying and using content from
industry-specific Knowledge Coach titles. These titles are based on the Knowledge-Based Audit
methodology, developed by CCH authors. To read more about this audit methodology and approach,
do one of the following:
Insert the Knowledge Coach workpaper RES-001 KBA Methodology Overview into a binder. See
Inserting Knowledge Coach Workpapers below for more information.
From any open Knowledge Coach Workpaper, click KC Guidance in the Guidance group on
the Knowledge Coach Ribbon. This displays the contents from RES-001 KBA Methodology
Overview in a separate Help window.
This workpaper is the roadmap or guide to the risk-based audit methodology that Knowledge Coach
follows. While it is not intended to replace the CCH audit guide, it provides extensive information
about the methodology and how the workpapers are intended to fit within that methodology.

Inserting Knowledge Coach Workpapers
To begin using the Knowledge Coach module, you must first insert Knowledge Coach workpapers. To
add a new Knowledge Coach workpaper to a binder in CCH ProSystem fx Engagement, do the
following:

1. Open the binder and select the tab into which you want to insert the Knowledge Coach
workpaper.
2. From the binder menu, select File > New > Knowledge Coach Workpaper . The New
Knowledge Coach Workpaper dialog displays.
3. Use the Industry list to select the Knowledge Coach title containing the workpaper(s) you are
adding. The name of each title includes the year for the title (“2014”), the industry name (e.g.,
“Commercial”), the date that CCH released the title (e.g., “7/18/14”), followed by the date that
your firm added the title (e.g., “7/18/14”).
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Notes:
You will not see the Base Title in the Industry List since workpapers are not inserted from
the Base Title.
Titles that have been added to the database can be viewed by any user. However, only a
user with appropriate staff group rights has the right to insert workpapers from
unreleased titles. For more information, see Getting Title Content on page 6.
After you insert Knowledge Coach workpapers into a binder, you will be able to update to
a later version when it is available. See Chapter 12 - Updating to a Later Version of a
Workpaper on page 54 for more information.

4. Select Add Independent Workpapers without Foundation Workpapers if you are
inserting only independent workpapers from another title into this binder.
5. Expand a category to display the workpapers contained within it.
6. Select the workpaper(s) you want to add. When you highlight a workpaper, its description
displays to the right.
Notes:
The first time you insert Knowledge Coach workpapers, the foundation workpapers1 are
selected automatically and cannot be deselected. For more information, see Foundation
Workpapers on page 15.
Some workpapers require an association to be made between the workpaper and
information that has been provided in other workpapers. For example, if you try to insert
AUD-800 Audit Program - (Custom), you will be asked to associate the audit program
workpaper you are inserting with a custom audit area you have set up in AUD-100
Tailoring Questions Workpaper. See Associate Workpaper on page 15 for more detail.
Once you have added major programs in KBA-101 or AID-303 and navigate back to the
Insert screen, secondary foundation workpapers can be found in Single Audit titles.
These workpapers include: KBA-502, AID-501, and KBA-103.

Tips:
To get to a workpaper quickly, expand a category and put your focus in the list of
Knowledge Coach workpapers by highlighting one of them. Then quickly type the first
few characters of the workpaper index (e.g. “AUD”). This takes you to the next instance
of a workpaper starting with those characters within the expanded category.
To insert more than one copy of an AUD-800 series audit program:

i. Create a Custom Audit Area in AUD-100 (e.g. Cash-2) see Adding a Custom
Audit Area on page 37.
ii. Select the custom audit area in the dialog.

1Workpapers that are always needed in the binder in order for the flow of information to work properly

between workpapers, and for the binder to comply with auditing standards.
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iii. Open the Insert Workpaper dialog and insert the custom audit program (AUD800).
iv. Select the custom audit area that you added in step ii.
v. Select which audit area you want to use to populate your custom audit program.
The audit objectives, tailoring questions, and Program Step Library will be
populated to create a second blank version of the audit program for that audit
area.
You can add multiple custom audit programs and audit areas at one time if you have
created multiple custom audit areas.

7. Click OK. After all the workpapers have been created, the Selected Workpapers Properties
dialog displays, listing all of the workpapers you have selected.

8. Complete the following fields as applicable:
Index. Enter an index number for each workpaper, if necessary.
Workpaper Name . Required. You can edit the default workpaper name if necessary.
Associated values such as audit areas, specialists, service organizations, etc. will be
appended to the workpaper name when applicable. See Associate Workpaper on
page 15 for more information.
Tab Location . Select the tab where you want to insert each workpaper. The default is
the tab you selected in step 1.
9. Select from the following Roll Forward options:
Include in Roll Forward . The workpaper appears in the new binder created for the new
period.
Replace in the Roll Forward with later Knowledge Coach content. The Knowledge
Coach content will be replaced by a later version when the workpaper is opened in the
new rolled-forward binder. This is the default selection. For more details on information
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that will be retained, see Chapter 12 - Updating to a Later Version of a Workpaper on
page 54.

Notes:
If at least one related workpaper is set to be replaced with the later version, then
all related workpapers will be updated to the later version when the binder is
rolled forward. For more information and a list of related workpapers for the
Commercial title, see Related Workpapers on page 54.
All roll forward options can be changed later from the Workpaper Properties
dialog for a particular workpaper or in the Roll Forward Binder Wizard.
Some of the decisions for what data should be retained and how templates will be
updated upon roll forward will be made at the administrative level. These settings
can be distributed to staff members via the use of binder templates that include
Knowledge Coach workpapers with these settings already established.

10. Select one of the following roll forward options for Responses:
Note : The following options are not applicable to Excel® Knowledge Coach workpapers.
Use response roll forward setting . The Knowledge Coach workpaper will roll
forward each response according to the default roll forward setting for that response as
determined by CCH.
Keep all responses. The Knowledge Coach workpaper will retain the current
responses in all of the response areas in the new workpaper in the new binder.
Reset all responses. The Knowledge Coach workpaper will reset all of the response
areas in the workpaper to their default values in the new binder.
Note: If information is flowing into a workpaper where “Reset all responses” is
selected, the information flowing in will still appear in the workpaper if the
workpaper from which the data is flowing is set to retain this data. An example of
this is KBA-102 Engagement Completion Document, which summarizes
information from the Findings tables in the substantive audit programs. If the
substantive audit programs are set to “Keep all responses” but KBA-102
Engagement Completion Document is set to “Reset all responses,” you will still see
the data in KBA-102 Engagement Completion Document that flows in from the
substantive audit programs.
11. Select the following row customization and program step options, as applicable:
Note : The following options are not applicable to Excel® Knowledge Coach workpapers.
Merge Row Customizations. The new Knowledge Coach workpaper will merge the
new content with information about the rows that were added to or deleted from the
original workpaper, as well as text changes to rows in the original workpaper. These
items can be reviewed when you open the rolled forward workpaper in the new binder.
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Note : This option does not apply to audit programs. Custom steps in audit
programs can be identified in the program step library.
Keep Program Steps. The Knowledge Coach workpaper will retain the program steps
in the workpaper that are added from the Program Step Library. This option is available
only for audit programs for the substantive audit areas where the Program Step Library
is used.

Keep Custom Program Steps. Program steps you create from scratch in audit
program workpapers will be kept in the new workpaper. This option is available
only when the Keep Program Steps option is selected.

Keep Modified Program Steps. Modifications you make to added program
steps in audit workpapers will be kept in the new workpaper. This option is
available only when the Keep Program Steps option is selected.

12. If workpapers require the same tab location and roll forward option, you can select several
workpapers and click Edit Multiple Options. The Edit Multiple Options dialog displays, allowing
you to set these options for the selected workpapers. Click OK to close the Edit Multiple Options
dialog.

13. Click OK to insert the selected Knowledge Coach workpapers.
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Foundation Workpapers
The first time you insert Knowledge Coach workpapers into your binder, you will notice that some of
the workpapers are automatically selected and have a gray background in the New Knowledge Coach
Workpaper window. These workpapers are called foundation workpapers1, and they must be present
in your binder to use other Knowledge Coach functionality and workpapers.
Foundation workpapers include most of the Communication Hub workpapers, which are central to the
Knowledge-Based Audit Methodology used by the Knowledge Coach titles. The following explanation
is from RES-001 KBA Methodology Overview:
The Communication Hub is a collection of forms that are populated throughout the
audit with key information about the entity, including the overall audit strategy, fraud
risks and other risks of material misstatement, misstatements identified and other
findings, information to be communicated to management, and other items. The
Communication Hub helps members of the audit team to understand critical
information about the entity and ensures that important information is not overlooked
or hidden in the details of other forms.
Because of their importance to the audit process, most of the Communication Hub workpapers are
also foundation workpapers.
The entire group of foundation workpapers drives the direction of your audit and guides you through
determining the required areas for your audit. These workpapers are a required part of every
Knowledge Coach binder, because they allow information and logic to flow between workpapers.
Depending on the title, refer to the RES-010, RES-KCO, or KCO-001 document for a list of
workpapers for the appropriate title.

Associate Workpaper
Some workpapers require you to associate them with custom values, such as audit areas, specialists,
service organizations, and other items. Workpapers require an association when you need to have
more than one instance of a particular Knowledge Coach workpaper in your binder for each type of
item to which the workpaper is related. Making this association allows Knowledge Coach information
to flow properly between workpapers.
Depending on the title, refer to the RES-010, RES-KCO, or KCO-001 document for a list of
workpapers for the appropriate title.

1Workpapers that are always needed in the binder in order for the flow of information to work properly

between workpapers, and for the binder to comply with auditing standards.
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Inserting a Workpaper that Requires an Association
To insert a workpaper that requires an association, do the following:

1. Follow steps 1-4 in Inserting Knowledge Coach Workpapers on page 10.
2. Select one of the workpapers listed above that require an association. Its name and description
display to the right, along with information on what data is required prior to inserting the
workpaper. For example, in order in insert a custom audit program, you must first set up a new
custom audit area.
3. Select the workpaper you want to add. The Associate Workpaper with Custom Value window
appears, listing all of the valid items from which to choose.
Note : If you have not completed sections in other workpapers that store the custom values,
you receive an error message that the workpaper cannot be inserted without completing
additional information in your binder. The Description field provides directions about what
information to complete.
4. Select the item to associate with the workpaper you are inserting and click OK.
5. If you are inserting a custom audit area, you will be prompted to select a Program Step Library
to help populate the audit program. If you want to use steps that exist in a Program Step Library
for another (non-custom) audit area, select that audit area. If the steps are unique and not
included in another (non-custom) audit area, select "N/A."
6. The New Knowledge Coach Workpaper window now displays the custom value you selected in
place of “(Custom)” at the end of the workpaper name.
Note : If you have created multiple custom values (e.g. more than one custom audit area),
you can create the forms you need all at once by associating the workpaper with multiple
items. Once you have associated a particular custom value with a workpaper, it will no
longer be available in the Associate Workpaper with Custom Value window.
7. Click OK.
8. Continue with the rest of the steps for Inserting Knowledge Coach Workpapers on page 10.
Note : You will be prompted to make associations when inserting the workpapers that require this
association from related workpaper reference links or from missing workpaper diagnostics.
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Chapter 4

KNOWLEDGE COACH WORKPAPERS IN THE
BINDER
Chapter 4 - Knowl edge Coach W orkpapers i n the Bi nder

Once you have inserted Knowledge Coach workpapers into your binder, they will be listed along with
all of your other workpapers in your Engagement binder. Knowledge Coach workpapers are indicated
by a Knowledge Coach Word workpaper icon or a Knowledge Coach Excel® workpaper icon.
Knowledge Coach workpapers also take advantage of the Open Diagnostics column in the binder
frame. If a workpaper has diagnostics that have yet to be resolved, you will see the Open Diagnostics
icon next to the workpaper. For more details, see Chapter 13 - Diagnostics on page 57.
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Chapter 5

THE KNOWLEDGE COACH RIBBON
Chapter 5 - T he Knowl edge Coach Ri bbon

Knowledge Coach workpapers use either a Microsoft ® Word 2007/2010 or a Microsoft ® Excel®
2007/2010 medium for viewing the title content from the Knowledge Coach content database. The
Knowledge Coach ribbon in Word and Excel® includes many functions you’ll need while working with
Knowledge Coach workpapers.
The dynamic functionality of Knowledge Coach (such as hiding and showing parts of the workpapers,
flowing information between workpapers, diagnostics, and other functions) is available within Word
documents, as seen in the ribbon below:

You can access Knowledge Coach ribbon functions using Alt + C. Additional hot keys become visible
when holding down Alt + C. For example, Alt + C, S is Sign off.
Excel® Knowledge Coach workpapers also include some functionality, as shown in the Excel® ribbon
below:
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Knowledge Coach Ribbon Functionality
Ribbon
Group/Function

Icon

Available Available
in Word in Excel®

Description

Available
via
RightClick

General
Displays a drop-down menu so that
you can pause or resume
automatic refresh of Knowledge
Coach data, or manually refresh
Knowledge Coach data.

X

Pause Auto
Refresh

Stops the Knowledge Coach
information and links from being
refreshed automatically. If already
paused, clicking this button again
will resume automatic refresh.

X

Refresh
KC Data

Manually refreshes the Knowledge
Coach workpaper to include the
most recent information,
diagnostics, and links.

X

Opens the Knowledge Coach
WebHelp file.

X

Risk Summary

Allows you to view a summary of
all the risks within the Risk pane.

X

X

Add Risk

Displays a drop-down menu so you
can add a financial-statement level
risk or specific risk.

X

X

Financial
Statement
Level Risk

Allows you to add a financial
statement level risk from a financial
statement audit workpaper.

X

X

X

Specific Risk

Allows you to add a specific risk
from a financial statement audit
workpaper.

X

X

X

Pause Auto Refresh

Knowledge Coach
Help
Risk Assessment

Chapter 5 - The Knowledge Coach Ribbon • 19

Ribbon
Group/Function

Icon

Available Available
in Word in Excel®

Description

Available
via
RightClick

Major
Program
Level Risk

Allows you to add a major program
level risk from a single audit or
HUD compliance workpaper.

X

X

X

Compliance
Requirement
Level Risk

Allows you to add a compliance
requirement level risk from a single
audit or HUD compliance
workpaper.

X

X

X

Edit

Displays the Open Risk dialog so
you can edit a risk.

X

Delete

Deletes a risk.

X

Displays a drop-down menu for
Program Step Library options.

X

Program
Step Library

Opens or closes the Program Step
Library.

X

Modify

Displays a drop-down menu with
customization options for inserting
a new step or sub-step.

X

New Custom
Step

Allows you to insert a new custom
program step.

X

New Custom
Sub-Step

Allows you to insert a new custom
sub-step.

X

Remove
Step

Allows you to remove a program
step.

X

Find Step

Allows you to locate a step in the
Program step Library pane.

X

Opens or closes the Diagnostic
pane at the bottom of the
workpaper.

X

X*

Audit Programs
Program Step Library

X

Diagnostics

Diagnostics Pane

X
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Ribbon
Group/Function

Icon

Available Available
in Word in Excel®

Description

Find

Opens the Diagnostic pane (if it is
not already open) and scrolls to the
selected diagnostic within the
pane.

X

Delete

Deletes the diagnostics selected
within the diagnostics pane.

X

Sign Off

Inserts your initials and the current
date (depending on the sign-off
configuration).

X

Roll Forward
Settings

Opens the Roll Forward Settings
menu.

X

View
Responses
Set to Keep

Check this selection to view all
cells that are set to be retained
during roll forward.

X

View
Responses
Set to Reset

Check this selection to view cells
that are set to be reset during roll
forward.

X

Mark as N/A

Inserts N/A and the current date
(depending on sign-off
configuration).

X

Delete Sign Off

Deletes the information in the signoff field.

X

Reset Answer

Resets the selected cell to the
default state.

X

Tips

Displays the Tips pane to the right
of the workpaper.

X

Answer Effects

Displays the Answer Effects tab in
the Tips pane.

X

Available
via
RightClick

X*

Complete Cells

X*

Guidance

X

X
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Ribbon
Group/Function

Icon

Available Available
in Word in Excel®

Description

View Updates

Opens the View Content Updates
tab in the Tips pane, allowing you
to view significant updates to the
selected workpaper.

X

X

KC Guidance

Opens the Title Help file for the
associated Knowledge Coach title,
displaying the KBA Methodology
Overview.

X

X

ARM

Opens the CCH® Accounting
Research Management® Web site.

x

x

Opens the Customization Review
pane.

X

Displays a drop-down menu for
inserting rows into a Knowledge
Coach table.

X

Insert Row
Above

Inserts a row above the selected
row.

X

Insert Row
Below

Inserts a row below the selected
row.

X

Delete

Deletes the selected row.

X

Available
via
RightClick

Review
Customization
Review
Table

Rows

* Available from the right-click menu from within a table only.
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Chapter 6

IMPORTANT ELEMENTS IN KNOWLEDGE
COACH WORKPAPERS
Chapter 6 - Important El ements i n Knowl edge Coach W orkpapers

This section familiarizes you with the common elements of Knowledge Coach workpapers, including
the various links, tips, indicators, and table elements.

Embedded Hyperlinks
Most Knowledge Coach workpapers begin with introductory material that describes the purpose of the
workpaper and related instructions. Read this information to get familiar with the contents of the
workpaper. Once you are comfortable with the introductory material, you can quickly skip the purpose
and instructions by holding down the Ctrl key and clicking the Beginning of Form hyperlink at the top
of the workpaper.
To revisit the introductory material, use the Purpose and Instructions hyperlink to return to the top
of the workpaper.
Several workpapers also include “Next Steps,” which will help you decide where to go next with your
work once you complete the documentation in the open workpaper. Use the Next Step hyperlink to
jump back to this section in the instructions.

Related Workpaper Links
Throughout the body of Knowledge Coach workpapers, you’ll often see references to other
Knowledge Coach workpapers that are related to the audit material in which you are working. These
are shown in blue italicized text.
To use related workpaper links, do the following:

1. Double-click anywhere in the blue italicized text.
2. If the related workpaper is already in your binder, the workpaper will be opened for you.
Note : Related workpaper links in Knowledge Coach only look for other Knowledge Coach
workpapers in the binder. The system cannot recognize or open any Knowledge Tools
versions of workpapers from related workpaper links in Knowledge Coach.
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3. If the related workpaper is not already in your binder, you will be asked if you would like to insert
it. Do the following:
a. Click Yes to insert the workpaper into your binder. The New Knowledge Coach
Workpaper window displays with the related workpaper selected.
b. Click OK. The Selected Workpaper Properties window displays. For more details on this
screen, see Inserting Knowledge Coach Workpapers on page 10.
c. Click OK. The system asks if you would like to open the workpaper.
d. Click Yes to launch the workpaper.

Tips
When you see the Tips icon in a Knowledge Coach workpaper, you can view a Tip for that section.
Tips include additional guidance for completing checklists, audit programs and forms. Click the light
bulb to display the Knowledge Coach Tips Pane with the Tip for the associated section.
There are three categories of Tips:

Practice points provide additional guidance to assist you in completing Knowledge Coach
workpapers.
Examples are illustrations or sample calculations related to an element in the Knowledge
Coach workpaper (e.g., sample note disclosures or materiality calculations).
Resources refer you to authoritative literature (e.g., references to Statement on Auditing
Standards [SAS]).

"Do Not Delete" Indicators
When a section of a Knowledge Coach workpaper does not need to be completed due to the way you
answered a tailoring question, that section is hidden in the workpaper. In its place, you will see text
with a gray background that says “Do not delete this area of workpaper.”

Note : These sections contain information that Knowledge Coach requires in order to build the
workpaper correctly.
If one of these sections is inadvertently deleted, do the following:

1. Close the workpaper that contains the deleted section.
2. Select the workpaper in the binder frame and select Tools > Repair Knowledge Coach
Workpaper . This will regenerate the Knowledge Coach workpaper for you.
Information provided in the workpaper (answers to questions, customizations to rows, program steps,
sign offs, diagnostic states, etc.) will be kept intact and transferred to the repaired workpaper as long
as that information had been saved in the workpaper.
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Warning! Customizations you make outside of Knowledge Coach tables will not be retained in
the repaired workpaper. Therefore, if you have made a significant number of customizations to
instructional text or other information outside of tables, you should copy the workpaper to another
binder before you repair the workpaper so that you can make the changes again in the repaired
workpaper.
Tip : Save your work in Knowledge Coach workpapers often by selecting File > Save .

Knowledge Coach Tables
Most of the interactive information you’ll need to work with in Knowledge Coach is provided in the
form of tables in Microsoft ® Word. This section explains some of the important elements of
Knowledge Coach tables.

Answer Selection Boxes (Floaties)
You will choose answers to questions in Knowledge Coach tables using an answer selection box that
floats over the table to show the available choices; therefore, these boxes are informally called
floaties. Knowledge Coach uses prompts that say “choose an item” or “choose all that apply” in areas
where floaties are located.
To use a floatie, do the following:

1. Click the text prompt that says “choose an item” or “choose all that apply.” The floatie appears,
listing the choices for your answer in the form of radio buttons, a drop-down menu, or
checkboxes.
2. Use your mouse to select your choice or choices.
3. Once you have clicked out of the floatie, your answer appears in read-only text.
4. Wait a few seconds for your workpaper to refresh. A progress indicator displays.
Warning! While the workpaper is being refreshed, you cannot perform any functions in
Microsoft ® Word.
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Notes:
If the answer option is more than 20 characters, a tool tip will show the answer.
Floaties will not appear properly if you are using dual monitors on a laptop and your laptop
screen is NOT your primary monitor. To resolve this issue, flip your monitors to ensure that the
laptop screen is the primary monitor.
In some floaties, you can provide your own custom answer. If this is available, you will see text
that says “Add custom value." Enter your custom answer in the space provided and click OK. A
special instance of these customizable answers is the AUD-100 tailoring question about the
audit areas that are applicable to your engagement. For more details, see Audit Areas on
page 36.
For single-selection answers (radio buttons and drop-down menus), the floatie closes as soon as
you select an answer. For multiple-selection answers (checkboxes), the floatie stays open until
you have clicked or tabbed outside of the cell, so that you can select all of your choices.
In some floaties, answers will be recommended for you based on how you have responded to
other questions. In this case, you will see text that says “(Recommended)” after the choice that
is suggested. You can select a different answer, but if you do, a Potential Error diagnostic will be
generated for the question. See Chapter 13 - Diagnostics on page 57 for more details.

Tip : Instead of using your mouse, you can use the following keys to answer floaties:
The TAB key moves forward (left to right down the page) from one answer selection box
or table cell to the next. Hold the Shift key while pressing the TAB key to move
backwards.
The UP and DOWN arrows cycle through a selection list in an answer selection box.
The SPACEBAR will toggle a check box control or select an option in an answer selection
box.
The ENTER key will retain the answer and close an answer selection box.
The ESC key is equivalent to clicking a Cancel button.
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Cells with Open Diagnostics
A cell in a Knowledge Coach table that has an open diagnostic associated with it (unanswered
question, program step not signed off, potential error, etc.) is indicated with light blue shading on the
cell.
To view the diagnostic for the selected cell, do one of the following:
Choose Find from the Diagnostics group on the Knowledge Coach ribbon. This opens the
Diagnostics Pane, if it is not already open, and will automatically scroll to and select the open
diagnostic associated with the selected cell. You can also use the Find Diagnostic function on
the right-click menu from a selected cell.
Choose Diagnostics Pane from the Diagnostics group on the Knowledge Coach ribbon, if the
Diagnostics Pane is not already displayed at the bottom of your screen. Scroll to applicable
diagnostic.
For more information, see Chapter 13 - Diagnostics on page 57.

Note : Diagnostics are refreshed periodically as you work through the workpapers. However, if
you think a particular diagnostic should be cleared and you are still seeing an open diagnostic, you
can refresh the diagnostics manually. To do this, click Refresh KC Data on the General group
on the Knowledge Coach ribbon.

Cells that Flow To or From Other Areas
To save you time and protect consistent information, Knowledge Coach automatically flows some
information you provide to other workpapers. You can tell when information is coming from another
workpaper by the slanted gray shading on the background of certain cells in Knowledge Coach tables.
Cells that flow information in from another area of the workpaper are not editable. Instead, you
modify the information in the source document in order to keep the information the same in both
places. In many cases, you can drill down to the source of the information by double-clicking the blue
arrow inside the cell. This launches the workpaper that contains the original question and places your
focus directly in the cell from which the information is flowing.
When information is updated in one workpaper and it flows to another workpaper, thereby changing
the contents of the workpaper, the File Modified Flag icon is not displayed next to the workpaper that
changed as a result. However, there may be additional Unanswered Question diagnostics or other
diagnostics that appear, which will prompt you to complete more information in the affected
workpaper.
For more information, see Chapter 13 - Diagnostics on page 57.
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Form Tables
Many Knowledge Coach tables have the structure of a “form table,” in which you must add as many
rows as you need in order to accommodate the information you have.
Because the number of specialists you have involved on an audit may vary by engagement,
Knowledge Coach allows you to add as many rows as you need. To add rows to these kinds of tables,
do the following:

1. Click in the area of the table that uses the instructions, “Type here to add an item.” This text will
disappear.
2. Type relevant information in the cell.
3. Use your mouse or tab to the next cell in the table. Knowledge Coach will automatically add
another empty row below the one that contains your information. It may take a few seconds for
the system to completely refresh; you can watch the Word status bar at the bottom of the
workpaper to monitor the refresh process.
4. Complete the other cells in the row you have added, as applicable.

Findings Tables
A special kind of form table is the Findings Tables that are found in several documents, including each
of the substantive audit programs. If you use the Workpaper Identified In field in the risk pane, the
risk will show in the respective findings tables when applicable.
To protect the integrity of risk information throughout the Knowledge Coach workpapers, you are now
restricted from adding risks directly in the findings tables. This applies to the Single Audit title and all
titles released subsequent to KC 1.8.
For more information, see Form Tables (above) and Chapter 9 - Risk Summary on page 39.

Inserting Rows
Depending on the table, you will be able to insert rows in Knowledge Coach. To insert a row, do the
following:

1. Click in a row in Knowledge Coach table.
2. Using the Tables group, select Rows > Insert Rows Above or Insert Rows Below. The
Insert Knowledge Coach Row window displays.
3. Select the row type you would like to add and click OK. The new row is added, and renumbering
is applied if necessary.
Note : When you update your workpaper to the latest version, either during an active engagement
or during the roll forward process, you can review any rows that were added manually through this
process and either accept or reject them in the new version of the template.
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Deleting Rows
Depending on the table, you will be able to delete rows in Knowledge Coach. To delete a row, do the
following:

1. Click in a row in Knowledge Coach table.
2. Using the Tables group, select Rows > Delete Row. You are asked to confirm the deletion.
3. Click Yes to continue. The row is removed, and renumbering is applied if necessary.
Note : When you update a workpaper to the latest version, either during an active engagement or
during the roll forward process, review any rows that were deleted manually through this process
and either accept or reject the deletion in the new version of the template.

Information Outside of Tables
Customizations you make in text outside of Knowledge Coach tables in Microsoft ® Word cannot be
kept and merged with a new version of the Knowledge Coach workpaper. If the option to merge
changes is chosen as the roll forward setting, or if you update a workpaper on the fly from an active
Engagement binder, edits made outside of Knowledge Coach tables will not appear in the new
workpaper.

Using Other Engagement Functions in Knowledge Coach
Workpapers
Several Engagement functions you are used to using in non-Knowledge Coach workpapers are
available in Knowledge Coach Word and Excel® workpapers. Available functions include the
following:
Insert workpaper reference
Open workpaper reference
Create workpaper note
Insert tickmark (available in Excel® Knowledge Coach workpapers only)
To use these functions, click on the Engagement ribbon at the top of Knowledge Coach workpapers.
Some of the functions are also available from the right-click menu in Knowledge Coach workpapers.
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Using Microsoft® Word Functions in Knowledge Coach
Workpapers
Most Microsoft ® Word and Excel® functions are available in Knowledge Coach workpapers without
restriction. However, there are some functions that are limited in Knowledge Coach Word workpapers
due to the way that Knowledge Coach information is stored and used within the application.
Restrictions are put in place to protect the integrity of your data and include the following:

Copy/paste . You can copy/paste text inside of Knowledge Coach Word tables, but that text will
be pasted as unformatted. You cannot copy/paste responses to questions from answer
selection boxes (“floaties”). You also cannot copy entire rows of information (program step rows,
etc.) to other tables. If you attempt to copy and paste restricted information and your workpaper
becomes unusable, you can repair the workpaper.
Undo/redo . The undo and redo functions are not available for Knowledge Coach Word
workpapers, even though the ribbon icon might be illuminated in Word. Therefore, exercise
caution when deleting a row or when accepting the confirmation message to change or reset an
answer, as you will not be able to undo these decisions.
Insert Ribbon . Items in the Tables, Illustrations and Text groups on the Insert tab of the
Microsoft ® Word ribbon are disabled when you are working in a Knowledge Coach table. You
may insert these items outside of a table; however, you should not overwrite existing text or
tables.
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Chapter 7

TIPS PANE
Chapter 7 - T i ps Pane

Information that supplements the content in Knowledge Coach workpapers in Microsoft ® Word is
displayed in the Tips Pane. Access the Tips Pane by selecting Tips from the Guidance group on the
Knowledge Coach ribbon. Three elements display in the Tips Pane: Tips, Answer Effects, and
Content Updates.

Note : You can drag the Tips Pane to another monitor and then resize it as desired. Double-click
on the heading to dock it back to the original location.

Tips
When you see the Tips icon in a Knowledge Coach workpaper, you can view a Tip for that section.
Tips include additional guidance for completing checklists, audit programs and forms. Click the light
bulb to display the Knowledge Coach Tips Pane with the Tip for the associated section.
There are three categories of Tips:

Practice points provide additional guidance to assist you in completing Knowledge Coach
workpapers.
Examples are illustrations or sample calculations related to an element in the Knowledge
Coach workpaper (e.g., sample note disclosures or materiality calculations).
Resources refer you to authoritative literature (e.g., references to Statement on Auditing
Standards [SAS]).

Answer Effects
The Answer Effects tab on the Tips Pane provides transparency so that you know how Knowledge
Coach treats the audit information in your binder in terms of logic and flow. It lists how the selected
content affects other workpapers or other sections of the open workpaper. It also lists how the
selected content is affected by other workpapers or other sections of the open workpaper.
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Accessing the Answer Effects Tab
To access the Answer Effects tab on the Tips Pane, do the following:

1. Highlight or place your cursor in the section of the workpaper for which you want to view answer
effect information.
2. Select Answer Effects in the Guidance group of the Knowledge Coach ribbon. You can also
select the Answer Effects tab on the Tips Pane any time it is opened.
3. The answer effects for that area of the workpaper display in the Answer Effects tab on the Tips
Pane.
4. When no answer effects are present for that section of the workpaper, a message displays along
with a list of the top Knowledge Coach usability tips.
Note : The light bulb icon that signifies that there is a tip associated with the content in the
workpaper is not shown in tables when the specific area of the workpaper has only Answer Effects
associated with it and there are no tips. Outside of tables, both tips and/or answer effects will
display the light bulb visual indicator.

Examples of Answer Effects
The Answer Effects section lists the following conditions that are applicable to the selected area of the
workpaper:

Heading in
Answer
Pane

Show
Content

Details That are Displayed

Example

Information that will be shown
when you answer the selected
question
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Heading in
Answer
Pane
Content
Shown
When

Details That are Displayed

Example

Questions that cause the
selected content to show

Other areas in the workpapers to
Flow Answer
which the selected content will
To
flow

Flow Answer Where the selected content is
From
flowing from

Workpaper
to Consider

Specific workpapers that are
recommended for consideration
based on how the question is
answered

Consider
Workpaper
When

Questions that cause the open
workpaper to be considered

Questions that cause the
Recommend
selected question to have
Answer
answers that are recommended
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Heading in
Answer
Pane

Details That are Displayed

Example

Program steps that will be
marked as Not Applicable (N/A)
N/A Program
in the Program Step Library Pane
Steps
when the selected question is
answered a certain way

Viewing the Details of Each Answer Effect
To view the details of each answer effect listed, click on the answer effect (i.e. “Show Content”). The
information will be shown in the bottom section of the Tips Pane.
In the case of Microsoft ® Excel® workpapers, the answer effects are displayed similarly as in
Microsoft ® Word. To view answer effects while in Microsoft ® Excel®, do the following:

1. In a Knowledge Coach Excel® workpaper, select the Answer Effects item from the Guidance
group on the Knowledge Coach ribbon.
2. The Tips Pane will open with the Answer Effects tab pre-selected.
3. Answer effects in Microsoft ® Excel® will display workpaper-level answer effects for when the
workpaper should be considered.
You can also access a complete list of the answer effects for a particular workpaper from the KC
Guidance item accessed from the Knowledge Coach ribbon in either Microsoft ® Word or Excel®.
Follow these steps:

1. In a Knowledge Coach workpaper, select the KC Guidance item from the Guidance group on the
Knowledge Coach ribbon. The HTML Help file will display.
2. From the Contents tab on the left-hand side, select the open workpaper by clicking on the purple
book, using the index and workpaper name as a guide.
3. Select the Answer Effects topic within the desired workpaper to view the details of the
information.

Content Updates
The Content Updates section of the Tips Pane displays information about what has changed in the
open workpaper, as compared to previous versions.
In Knowledge Coach workpapers in Microsoft ® Word or Excel®, you can view the updates by doing the
following from anywhere in the open workpaper:

1. Click View Updates in the Guidance group on the Knowledge Coach ribbon. You can also
select the View Content Updates tab in the Tips Pane any time it is open. A summary of the
updates for the workpaper is displayed in the Content Updates tab on the Tips Pane.
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2. If there are no updates for the opened workpaper, a message displays along with a list of the top
Knowledge Coach usability tips.
You can continue to work on the workpaper as you view the updates.
You can also view the content update information for a particular workpaper from the KC Guidance
item accessed from the Knowledge Coach ribbon in either Microsoft ® Word or Excel®. Follow these
steps:

1. Select the KC Guidance item from the Guidance group on the Knowledge Coach ribbon. The
HTML Help file displays.
2. From the Contents tab on the left-hand side, select the open workpaper by clicking on the purple
book, using the index and workpaper name as a guide.
3. Select the Content Updates topic within the desired workpaper to view the summary information
for any updates.
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Chapter 8

TAILORING YOUR WORKPAPERS
Chapter 8 - T ai l ori ng Your W orkpapers

This section explains the various methods of tailoring your workpapers in Knowledge Coach, including
tailoring questions, audit areas, and changing your answers.

Tailoring Questions
When you answer certain questions in a Knowledge Coach workpaper in Microsoft ® Word, the
contents of your workpapers dynamically change based on your answers to display only the
information pertinent to your audit. These tailoring questions are meant to mimic the thought process
that an experienced practitioner would ask themselves as they document their audit procedures. The
tailoring questions are located in various workpapers. The main areas where you’ll see tailoring
questions are:
AUD-100 Overall Tailoring Questions
AUD-800 Series Audit Programs
The location and content of tailoring questions may vary by industry title.
You use answer selection boxes, or “floaties,” to answer tailoring questions. For more details see
Answer Selection Boxes (Floaties) on page 25. To see what will happen when you answer a tailoring
question a certain way, use the Answer Effects function from the Knowledge Coach ribbon. For more
information, see Answer Effects on page 31.

Audit Areas
An important tailoring question asks you to select the audit areas that are applicable to your
engagement. This question is found in most titles except Compilations, Reviews, and Nontraditional
Engagements. The answer to this question will drive the contents of many other foundation
workpapers by dynamically adding sections for each audit area you designate as applicable.
In the floatie for this question there is a list of audit areas specific to the industry title in which you are
working. Select the audit areas for your engagement here.
You can add, edit, and delete custom audit areas for the entity. Access the Audit Areas window by
clicking Customize audit areas.
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Tip : In order to add multiple copies of an audit program, create additional copies of an audit area
by adding custom audit areas. See Inserting Knowledge Coach Workpapers on page 10 for
more information on inserting multiple copies of an audit program.

Adding a Custom Audit Area
1. Click Add . The Add Audit Area window displays.
2. Provide a name for the new audit area. Keep the name to under 30 characters.
3. Click Add on the Add Audit Area window. The new audit area displays in the Available audit
areas box, with a Custom Item icon to the right.
4. Click OK to save the new audit area. The new audit area will appear at the bottom of the
available audit areas in the floatie.
5. Select the checkbox next to the new audit area in the floatie to include it in your applicable audit
areas and click out of the floatie to save your selection.

Renaming an Audit Area
1. Select a custom item. If you are not sure which areas are customized, check for the Custom
Item icon to the right.
2. Click Rename . The Rename Custom Audit Area window displays.
3. Enter the new name and click OK. The new audit area name displays in the Available audit
areas box of the Audit Areas window.
Note : You can only rename custom audit areas.

Deleting an Audit Area
1. Select a custom audit area. If you are not sure which areas are customized, check for the
Custom Item icon to the right.
2. Click Delete . A message displays asking you to confirm the procedure.
3. Click Yes to remove the custom audit area from the available audit areas list.
4. Click OK to close the dialog box. The floatie displays with the deleted value(s) excluded from
the list.
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Changing an Answer
You can change an answer that was previously provided. If you change an answer that controls the
behavior of other areas in your Knowledge Coach workpapers, you will be warned about this so that
you do not inadvertently remove information.
To change an answer, do the following:

1. Click on the existing answer. The floatie appears with the current response pre-selected.
2. Select a different choice. The Change Answer Notification window displays.
3. Click Yes on the Change Answer Notification window. The answer is updated with your new
choice.
Note : Clicking on Reset Answer from the Complete Cells group on the Knowledge Coach ribbon
is another way of changing an answer. Therefore, you will see the same warning when resetting
an answer in a Knowledge Coach workpaper.
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Chapter 9

RISK SUMMARY
Chapter 9 - Ri sk Summary

Risks can be accumulated in a central area called the Risk Summary within a Knowledge Coach
binder. This summary can be accessed from any open Knowledge Coach Word or Excel® workpaper.
Also, risk information flows to various workpapers, as applicable, so that you always see the risk
information you need to work with within the context of appropriate workpapers.
The Risk Summary window allows you to view and delete risks that have been identified in the current
binder and select risks to be edited. Risks are categorized by Knowledge Coach title and then divided
into Financial Statement Level Risks, Specific Risks, Major Program Level Risks, and Compliance
Requirement Level Risks.
To view the Risk Summary, click Risk Summary from the Risk Assessments group on the Knowledge
Coach ribbon.
To navigate through the risks, do the following:

1. Expand the Knowledge Coach title by clicking on the plus sign next to the title to view the type of
risks associated with the title.
2. Expand each risk type by clicking on the plus sign next to the risk type name to view a list of the
risks that have been identified in that category.
3. Expand each risk by clicking on the plus sign next to the risk to view the workpaper index and
name where the risk is addressed, the planned overall response or comment on planned audit
approach (if applicable), and the name of any program step(s) that have been linked to address
the risk.
Notes:
Risks can only be added for the title of the open workpaper. For example, if you have
KBA Commercial workpapers opened, risks cannot be added to KBA Construction workpapers.
Risks cannot be added to independent workpapers that do not include foundation workpapers.1
You must be the current editor of KBA-502 Summary of Risk Assessments to add, edit, or delete
risks.

1Workpapers that are always needed in the binder in order for the flow of information to work properly

between workpapers, and for the binder to comply with auditing standards.

Chapter 9 - Risk Summary • 39

Adding Financial Statement Level Risks
You can add a financial statement level risk, which will then appear in KBA-502 Summary of Risk
Assessments and all substantive audit programs. You can document a planned overall response for
each financial-statement-level risk, and you can optionally link one or more program steps in a
substantive audit program to the risk using the unique risk name you have created.

Notes:
One financial-statement-level risk, "Management Override," is provided. The description for this
risk can be edited and a planned overall response can be added, but it cannot be renamed or
deleted.
You must be in a financial statement audit workpaper to add a financial statement level risk.
You must be the current editor of KBA-502 Summary of Risk Assessments to add a risk.
To add a financial-statement-level risk, do the following:

1. Select Add Risk > Financial-Statement-Level Risk from the Knowledge Coach Ribbon, or
click Risk Summary to display the Risks Pane, and then select the Financial-StatementLevel Risk section.
2. Complete the following fields:
Risk name . Required. This name will be used when you link program steps to the risk.
Warning! You cannot enter the pound sign (#) or the pipe symbol ( | ) in the Risk
name field.
Risk description . Required. This box has a maximum of 512 characters.
Type of risk. Required. See the instructions in KBA-502 Summary of Risk Assessments
for more information on factors to consider in determining whether a risk is significant
and/or may be related to fraud.
Planned overall response . Possible responses to risks at the financial statement level
are listed in the instructions to KBA-502 Summary of Risk Assessments, and incorporate
guidance from SAS-99. You’ll need to enter information here in order to clear the
Unaddressed Risk diagnostic for a particular risk.
Workpaper identified in . The open workpaper is selected as the default, but you can
change this. In audit programs, this selection results in the risk being added to the list of
Findings in the Results section of the audit program.
3. Click Save to save the financial statement level risk.
The newly added risk will appear in the Financial Statement Level Risks table in the Knowledge
Coach workpaper KBA-502 Summary of Risk Assessments.

Note : Use the drill-down icon to get to the substantive audit programs, from which you can link
specific program steps to this financial statement level risk, if desired. For more details, see
Linking a Program Step to a Risk on page 53.
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Adding Specific Risks
Specific risks are summarized in KBA-502 Summary of Risk Assessments and in the substantive audit
programs for the audit area(s) to which the risk is associated. You can link one or more program steps
in a substantive audit program to a specific risk using the unique risk name you have created.
Before any specific risks are created for a significant audit area, you’ll see information to this effect in
various parts of the workpapers. For example, in KBA-502 Summary of Risk Assessments, you’ll see a
row that says “No risks have been added for this area.”

Notes:
You must be in a financial statement audit workpaper to add a financial statement level risk.
You must be the current editor of KBA-502 Summary of Risk Assessments to add a risk.
To add a specific risk, do the following:

1. Select Add > Specific Risk from the Knowledge Coach Ribbon, or click Risk Summary to
display the Risks Pane, and then select the Specific Risk section.
2. Complete the following fields:
Risk name . Required. Maximum 30 characters. This name will be used when you link
program steps to the risk.
Warning! You cannot enter the pound sign (#) or the pipe symbol ( | ) in the Risk
name field.
Risk description . Required. This box has a maximum of 512 characters.
Type of risk. Required. See KBA-502 Summary of Risk Assessments for more
information on factors to consider in determining whether a risk is significant and/or may
be related to fraud. A risk may also require tests of controls, where substantive tests
alone are not sufficient.
Audit areas affected by the risk. Required. Select one or more audit areas that are
impacted by the risk. All audit areas are shown here, including custom audit area you
have added.
Cash transaction cycle . Required for audit areas Cash and Other Revenues and
Expenses. Select which cash transaction cycle applies to the identified risk.
Relevant assertions. Required. Choose from the following:
EO . Existence or Occurrence
RO . Rights and Obligations
CO . Completeness
AV. Allocation or Valuation
CU. Cutoff
UC. Understandability or Classification
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Note : The assertion definitions change with the clarified version of the titles.
Controls, if any, that mitigate specific risk. Evaluate the design of controls for each
significant risk or fraud risk. The magnitude of a risk depends in part on whether controls
are in place to mitigate those risks.
Combined risk assessment. Inherent Risk (IR) is combined with Control Risk (CR) to
determine the Risk of Material Misstatement (RMM) for each risk. The RMM level will be
recommended for you, based on the table found in the instructions at KBA-502 Summary
of Risk Assessments.
Planned audit approach . Required. Choose from the following:
Combined Approach . Audit plan consists of both tests of controls and
substantive tests.
Substantive: Analytical. Audit plan consists primarily of analytical procedures.
Substantive: In-Depth . Audit plan consists of both analytical procedures and
tests of details.
Comment on planned audit approach . Use this field to document a brief description
of the work you are planning, to act as a guide for linking specific program steps to this
risk when you design the audit program.
Workpaper identified in . The open workpaper is selected as the default, but you can
change this. In audit programs, this selection results in the risk being added to the list of
Findings in the Results section of the audit program.
3. Click Save to save the specific risk.
The newly added risk appears in the Specific Risks table in the Knowledge Coach workpaper KBA-502
Summary of Risk Assessments in the section for the associated audit area. If the risk is related to
more than one audit area, the risk will be shown separately in each of the audit areas.
The risk also will be shown in the Risk Summary window, and will flow to the substantive audit
program for the audit area to which it is associated.

Note : Use the drill-down icon to easily get to the substantive audit programs, from which you can
link specific program steps to this risk, if desired. For more details, see Linking a Program Step to
a Risk on page 53.

Adding Major Program-Level Risks
You can add a major program-level risk, which will then appear in the KBA-502S Summary of Risk
Assessment over Compliance for the associated major program and all substantive audit programs
associated with that major program. You can document a planned overall response for each major
program-level risk, and you can optionally link one or more program steps in a substantive audit
program to the risk using the unique risk name you have created.
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Note : KBA-502S Summary of Risk Assessment over Compliance for the applicable major
program must be in the binder and you must be the current editor of KBA-502S for the major
program to add a risk.
To add a major program-level risk, do the following:

1. Select Add Risk > Major Program-Level Risk from the Knowledge Coach Ribbon, or click
Risk Summary to display the Risks Pane, and then select the Major Program-Level Risk
section.
2. Complete the following fields:
Major Program Name . Required. This will link the risk to the correct major program.
Risk name . Required. This name will be used when you link program steps to the risk.
Warning! You cannot enter the pound sign (#) or the pipe symbol ( | ) in the Risk
name field.
Risk description . Required. This box has a maximum of 512 characters.
Type of risk. Required. See the instructions in KBA-502S Summary of Risk
Assessments over Compliance for more information on factors to consider in
determining whether a risk is significant.
Planned overall response . Possible responses to risks at the major program level are
listed in the instructions to KBA-502S Summary of Risk Assessments over Compliance.
You’ll need to enter information here in order to clear the Unaddressed Risk diagnostic
for a particular risk.
Workpaper identified in . The open workpaper is selected as the default, but you can
change this. In audit programs, this selection results in the risk being added to the list of
Findings in the Results section of the audit program.
3. Click Save to save the major-program-level risk.
The newly added risk will appear in the Major Program-Level Risks table in the Knowledge Coach
workpaper KBA-502S Summary of Risk Assessments over Compliance for the associated major
program.

Note : Use the drill-down icon to get to the substantive audit programs, from which you can link
specific program steps to this major program-level risk, if desired. For more details, see Linking a
Program Step to a Risk on page 53.

Adding Compliance Requirement-Level Risk
Compliance requirement-level risks are summarized in KBA-502S Summary of Risk Assessment over
Compliance for the associated major program and in the substantive audit program for the major
program and compliance requirement(s) to which the risk is associated. You can link one or more
program steps in a substantive audit program to a compliance requirement level risk using the unique
risk name you have created.

Chapter 9 - Risk Summary • 43

Before any compliance requirement level risks are created for a significant audit area, you’ll see
information to this effect in various parts of the workpapers. For example, in KBA-502S Summary of
Risk Assessment over Compliance for the associated major program, you’ll see a row that says “No
risks have been added for this area.”

Note : KBA-502S Summary of Risk Assessment over Compliance for the applicable major
program must be in the binder and you must be the current editor of KBA-502S for the major
program to add a risk.
To add a compliance requirement-level risk, do the following:

1. Select Add Risk > Compliance Requirement-Level Risk from the Knowledge Coach
Ribbon, or click Risk Summary to display the Risks Pane, and then select the Compliance
Requirement-Level Risk section.
2. Complete the following fields:
Major Program Name . Required. This will link the risk to the correct major program.
Risk name . Required. This name will be used when you link program steps to the risk.
Warning! You cannot enter the pound sign (#) or the pipe symbol ( | ) in the Risk
name field.
Risk description . Required. This box has a maximum of 512 characters.
Type of risk. Required. See the instructions in KBA-502S Summary of Risk
Assessments over Compliance for more information on factors to consider in
determining whether a risk is significant. A risk may also require tests of controls, where
substantive tests alone are not sufficient.
Compliance requirements affected by the risk. Required. Select one or more
compliance requirements that are impacted by the risk.
Controls, if any, that mitigate specific risk. Evaluate the design of controls for each
significant risk or fraud risk. The magnitude of a risk depends in part on whether
controls are in place to mitigate those risks.
Combined risk assessment. Inherent Risk (IR) is combined with Control Risk (CR) to
determine the Risk of Material Noncompliance (RMN) for each risk. The RMN level will
be recommended for you, based on the table found in the instructions at KBA-502S
Summary of Risk Assessment over Compliance.
Planned audit approach . Required. Choose from the following:
Dual-purpose tests
Substantive compliance tests

Comment on planned audit approach . Use this field to document a brief description
of the work you are planning, to act as a guide for linking specific program steps to this
risk when you design the audit program.
Workpaper identified in . The open workpaper is selected as the default, but you can
change this. In audit programs, this selection results in the risk being added to the list
of Findings in the Results section of the audit program.
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3. Click Save to save the compliance requirement-level risk.
The newly added risk appears in the Compliance Requirement-Level Risks table in the KBA502S
Summary of Risk Assessment over Compliance for the associated major program in the section for
the associated compliance requirement. If the risk is related to more than one compliance
requirement, the risk will be shown separately in each of the compliance requirements. The risk also
will be shown in the Risk Summary window, and will flow to the substantive audit program for the
compliance requirement to which it is associated.

Note : Use the drill-down icon to get to the substantive audit programs, from which you can link
specific program steps to this compliance requirement-level risk, if desired. For more details, see
Linking a Program Step to a Risk on page 53.

Editing Risks
Note : You must be the current editor of KBA-502 Summary of Risk Assessments to edit a risk.
To edit a risk in the Risk Summary window, do the following:

1. Click Risk Summary from the Risk Assessment group on the Knowledge Coach ribbon to
display the Risks Summary window.
2. Select the desired risk.
3. Click Edit Risk. The Financial-Statement-Level Risk section or the Specific Risk section opens,
depending on the type of risk you selected.
To edit a risk in KBA-502 Summary of Risk Assessments, do the following:

1. Locate the risk in KBA-502 Summary of Risk Assessments and place your cursor on that row.
2. Click Edit from the Risk Assessment group on the Knowledge Coach ribbon, or right-click and
select Edit Risk. The Financial Statement Level Risk section or the Specific Risk section opens,
depending on the type of risk you selected.
For more information, see Adding Financial Statement Level Risks on page 40, Adding Specific
Risks on page 41, Adding Major Program-Level Risks on page 42, and Adding Compliance
Requirement-Level Risk on page 43.
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Deleting Risks
To delete a risk from the Risks Pane, do the following:

1. Click Risk Summary in the Risk Assessment group on the Knowledge Coach ribbon to display
the Risks Pane.
2. Select the risk you want to delete.
3. Click Delete Risk.
4. Click Yes to confirm the deletion.
To delete a risk from KBA-502 Summary of Risk Assessments, do the following:

1. Locate the risk in KBA-502 Summary of Risk Assessments and place your cursor on that row.
2. Click Delete from the Risk Assessment group on the Knowledge Coach ribbon.
3. Click Yes to confirm the deletion.
Note : You cannot delete the "Management Override" Financial-Statement-Level risk, as this risk
always applies.
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Chapter 10

AUDIT PROGRAMS
Chapter 10 - Audi t Programs

The substantive audit programs in Knowledge Coach are based on a common organizational structure
so that every program you open for the various audit areas is the same. This includes custom audit
programs you create for the custom audit areas in your binder. For more details about custom audit
programs, see Audit Areas on page 36 and Associate Workpaper on page 15.

Note : When inserting a custom audit program, you have the option to select a Program Step
Library from an existing (non-custom) audit area to begin building the program. If an area is
selected, the program steps from that library will be available and the tailoring questions and
audit objectives will be populated based on the audit area selected. If you do not choose a
Program Step Library, the custom audit program will not contain any program steps in the library
when it is created. It also will not contain tailoring questions or the ability to mark steps as "Not
Applicable" based on how questions are answered. You will build the program steps from scratch
in these custom audit programs.

Program Step Library
The Program Step Library Pane displays all the program steps for a particular industry title so that you
can build and customize the audit program for each audit area and/or compliance requirement. When
you answer the tailoring questions in each audit program workpaper, Knowledge Coach uses your
answers to determine which program steps are applicable and which program steps are not
applicable.
The Program Step Library Pane is available only within the substantive audit programs, which are
found in the 800 Series of workpapers, whose index number and name are specific for each KC Title.
For example, AUD-800 Audit Program – (Custom) through AUD-818 Audit Program - Share-Based
Payments in the clarified version of the Commercial title.

View Available Program Steps
Program steps for each audit area are displayed in the Program Step Library Pane. To see the
program steps, open a substantive audit program (AUD-800 Audit Program – (Custom) through AUD818 Audit Program - Share-Based Payments in the clarified version of the Commercial title). The
Program Step Library Pane opens on the right-hand side of the screen.
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The audit area is displayed at the top of the screen. A short name is displayed for each of the program
steps for the audit area/industry title so you can quickly see what steps are available. Expand each
program step name by clicking on the plus sign next to the program step to view the full text of the
program step. The right-hand column displays the assertions for each program step. The assertions
are as follows:

EO . Existence or Occurrence
RO . Rights or Obligations
CO . Completeness
AV. Accuracy, Valuation, or Allocation
CU. Cut Off
UC. Understandability or Classification
Notes:
The assertion definitions change with the clarified version of the titles.
If the Program Step Library pane is closed and you want to reopen it, click Program Step Library
from the Audit Programs group on the Knowledge Coach ribbon.
The Program Step Library Pane can be moved and resized. The columns can also be resized, so
that you can read the steps more easily.

Tailor Steps in the Program Step Library
Before you add program steps from the Program Step Library to your audit program workpaper, you
should answer the tailoring questions for that audit area. This will help you narrow down the program
steps that might be applicable to your engagement.
For more information on answering questions, see Answer Selection Boxes (Floaties) on page 25.
As you answer these questions, steps in the Program Step Library will be marked as not applicable.
These steps are denoted by an NA notation in the column to the right of the program step name.

Add Steps from the Program Step Library
To add steps to your audit program, do the following:

1. Check Show only applicable steps to limit the displayed steps (optional).
2. Expand and collapse the main program steps by clicking the plus and minus signs.
3. Select the check box to add a program step to the workpaper. If you do not want to include a
particular sub-step in the workpaper, clear the check box.
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Notes:
If some of the sub-steps have been excluded, the checkbox will indicate this mixed
selection.
To select all of the steps at once, click the checkbox in the Program Step column
header.

4. Click Update Workpaper . The selected program steps are added to the workpaper.
Notes:
The program steps that you added will continue to have the checkmark next to them in the
Program Step Library so that you can always see which steps are in your workpaper.
To quickly locate a step in the Program Step Library, select a step or sub-step within the
workpaper and, using the Audit Programs group on the Knowledge Coach ribbon, click Program
Step Library > Find Step . The step or sub-step will be highlighted in the Program Step Library
Pane. You can also drag steps into the Program Step Library.

Modify a Program Step in the Workpaper
Once steps have been added from the Program Step Library to the workpaper, you can customize the
text of any step so that it fits your engagement.
To modify a step, do the following:

1. Locate the table in a substantive audit program that contains the program steps that have been
added. See Add Steps from the Program Step Library on the previous page for more
information.
2. Edit the step directly in the table in Microsoft ® Word.
3. Click out of the cell you have edited. A customization icon is displayed in the Program Step
Library to the right of each program step name, main program step, or sub-step that has been
modified.
Notes:
If you float your mouse over the step in the Program Step Library, you will see a tooltip that says
“Customized Step.”
If you have selected to include the Program Step Library from an existing (non-custom) audit
area, customizations within each workpaper are independent of other workpapers using the
Program Step Library for that audit area. If you customize the step in one audit program, it is not
automatically customized in the other audit programs.
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Add a Custom Program Step
You may want to add your own program steps to a substantive audit program to customize the
procedures to fit the needs of your engagement.
To add a custom step, do the following:

1. Locate the table in a substantive audit program that contains the program steps that have been
added.
2. Select the program step under which you would like to insert your new custom program step.
Note : If you would like to add a custom step to an audit program where no program steps
have been added, click on the row that says “No program steps have been added.” This is
especially applicable to AUD-800 Audit Program – (Custom), as no program steps can be
added to this workpaper from the Program Step Library if a Program Step Library was not
selected for the custom audit program; you must create custom steps in these custom audit
programs.
3. Add the custom step by doing one of the following:
Using the Audit Programs group on the Knowledge Coach ribbon, click Program Step
Library > Modify > New Custom Step .
Using the Table group on the Knowledge Coach ribbon and clicking Rows > Insert Row
Above or Insert Row Below. The Insert Knowledge Coach Row window displays. Click
OK to continue.

4. Two new rows are added to your table below the step you selected. The steps in the table are
renumbered automatically.
5. Enter a brief name for your custom step in the first row.
6. Enter the text for the program step in the second row, next to the step number.
7. In the Primary Assertions column, click on the cell next to the program step text to display the
list of assertions and select those that are applicable.
8. You can add a sub-step to your custom step by clicking Program Step Library > Modify >
New Custom Sub-Step from the Audit Programs group on the Knowledge Coach ribbon. A
row will be added beneath the main program step, in which you can enter the text of your substep.
Notes:
Custom steps are denoted in the Program Step Library by the customization icon that is
displayed to the right of each custom step’s program step name.
If you have selected to include the Program Step Library from an existing (non-custom) audit
area, custom program steps within each workpaper are independent of other workpapers using
the Program Step Library for that audit area. If you add a custom step in one audit program, it is
not automatically included in the Program Step Library for the other audit programs.
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Remove a Program Step
To remove a program step from an audit program, do one of the following:

Remove the Program Step from the Workpaper Using the Knowledge Coach
Ribbon
1. In the program step table within the workpaper, select the program step you want to remove.
2. Using the Audit Programs group on the Knowledge Coach ribbon, click Program Step
Library > Remove Step . The program step is removed from the Program Step Library.

Remove the Program Step from the Workpaper Using the Program Step Library
Pane
1. In the Program Step Library Pane, uncheck the step you want to remove.
2. Click Update Workpaper . The step is removed from the workpaper. It remains in the Program
Step Library in case you need to add it later.
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Chapter 11

LINKING RISKS TO PROCEDURES
Chapter 11 - Li nki ng Ri sks to Procedures

In Knowledge Coach, you can create a direct connection between risks that have been identified
throughout your audit and the procedures you design to address those risks. Financial statement level
risks and specific risks are summarized in KBA-502 Summary of Risk Assessments, and this
workpaper provides a snapshot of all of the risk information for the job at a glance. For Single Audit
titles, all steps selected in an audit program for a particular compliance requirement will flow to KBA502 as it is linked to the overall risk of non-compliance. Here is an example of the Specific Risks table
in KBA-502 Summary of Risk Assessments. Notice that in the Program Steps to Address Risk column,
there is an indication that “No steps have been linked.”

Risks are also flowed through to the substantive audit programs (AUD-800 Audit Program – (Custom)
through AUD-813 Audit Program – Other Revenue and Expenses and AUD-818 Audit Program - ShareBased Payments in the clarified version of the Commercial title). Financial statement level risks flow
through to all of the substantive audit programs, while specific risks only flow through to the audit
areas to which they relate.
Until risks are linked to program steps, open diagnostics will be present in your binder. For more
details, see Chapter 13 - Diagnostics on page 57.
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Linking a Program Step to a Risk
To link a program step to a risk, do the following:

1. Open a substantive audit program (AUD-800 Audit Program – (Custom) through AUD-818 Audit
Program - Share-Based Payments in the clarified version of the Commercial title) and scroll
down to the table that contains the program steps.
2. Click in the Link to Risk column for the program step you would like to link. A list of risks
appears, which includes all financial statement level risks for the binder and all specific risks
related to the particular audit area. The last selection, “Other Relevant Assertion,” is shown in
the event that you want to document the fact that the program step is being performed to satisfy
a relevant assertion for the audit area, instead of to satisfy an identified risk.
3. Select one or more risks, or select Other Relevant Assertion .
4. Click outside the floatie to close it. The risk name is displayed in the Link to Risk column. Also,
the program step name (e.g. “Receivables Analytical”) is shown in the risk summaries at the top
of the substantive audit programs and in KBA-502 Summary of Risk Assessments. Open
diagnostics for Unaddressed Risk, Program Step Not Linked to Risk or Relevant Assertion will
be cleared.
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Chapter 12

UPDATING TO A LATER VERSION OF A
WORKPAPER
Chapter 12 - Updati ng to a Later Versi on of a W orkpaper

With Knowledge Coach, you can update your workpaper to a later template at any time with a click of
a button. You don’t have to manually compare your workpaper to the later version of the workpaper
template to know you’re working with the most recent information. You don’t even have to wait to roll
forward your binder to get the later version of a particular workpaper.

Note : Knowledge Coach automatically replaces your workpaper with the later template when the
binder is rolled forward, unless you change the template settings in the roll forward options for the
workpaper. During the roll forward process, you will have the option to select which later version
you want to use. In most cases, the available titles will be the current year and the next year. To
update to a later title, you will have to update one year at a time. See Advancing More than One
Title Version on the next page.

Related Workpapers
Because many of the Knowledge Coach workpapers are related to one another through information
flow and the effects of answers, all related workpapers must be updated to the later version at the
same time.
Depending on the title, refer to the RES-010, RES-KCO, or KCO-001 document for a list of
workpapers for the appropriate title.

Updating a Workpaper to a Later Version
To update a workpaper in an open binder, do the following:

1. Ensure that all Knowledge Coach workpapers are closed.
2. Select a Knowledge Coach Word or Excel® workpaper and select Workpaper > Update to
Later Knowledge Coach Content. You can choose to either Update Selected Knowledge
Coach Workpapers or Update All Knowledge Coach Workpapers in Binder. If you have selected
a workpaper that links to another Knowledge Coach workpaper via information flow or tailoring
of content, you are warned that the entire set of related workpapers will be updated together.
See the previous section, Related Workpapers above for more information.
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3. Click OK to continue. If there are multiple title versions available, select which title version is
appropriate for your engagement. In most cases, the available titles will be the current year and
the next year. To update to a later title, you will have to update one year at a time. See
Advancing More than One Title Version below. You will see a progress indicator and then a
success message. You will be notified of any titles that are not successfully updated. In limited
instances (for example, when updating to the clarified version of the title), some workpapers
may not have an updated version. You will be notified that one or more workpapers were not
updated, but this does not mean that the update process was unsuccessful.
4. Open the updated workpaper. The new content is presented in the workpaper, along with the
work you did before you updated the workpaper (answers to questions, program step sign offs,
workpaper customization, etc.). The Customization Review window displays. A summary of the
changes to rows that were made displays.
Note : The Customization Review window may refer to customizations that are not visible
due to new tailoring that has been added during the content update. These customizations
will be visible when the new tailoring questions are answered. The new tailoring questions
might exist in the Tailoring Question Workpaper or within the workpaper itself.
Warning! There are limited circumstances where a workpaper may change or become
obsolete with the updated title version and a new workpaper needs to be manually inserted.
You will be notified via diagnostic when this is the case. The new version of the workpaper
will need to be inserted before the previous version is deleted or you will lose the work that
was done prior to the update. In some cases, the data will be automatically transferred, and
in other cases, you will have to manually transfer the data.
5. Click Close once all of the changes have been reviewed and accepted or rejected.
6. To view a general description of what has changed in the workpaper as compared to prior
versions, see details at Content Updates on page 34, or depending on the title, refer to the
RES-010, RES-KCO, or KCO-001 document for the appropriate title.

Advancing More than One Title Version
In most cases, you will not be able to skip a year when updating your title version. Sometimes new
workpapers are added. In order to preserve your data, the following steps should be performed to
advance more than one title version:

1. Select any available title on roll forward or update.
2. If there is a later title installed, you will be alerted there is a more recent title available for
update.
3. Open the binder and look for Obsolete Workpaper diagnostics.
4. Insert any workpapers indicated in the diagnostics.
5. Insert the Entity Information and Background form (KBA-200) if it is available.
6. Either roll forward the binder again or update all Knowledge Coach workpapers to the next title
from within the binder. See Updating a Workpaper to a Later Version on the previous page.
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Note : The above steps have to be performed updating one year at a time. All sequenced title
versions will have to be installed in order to get to the very latest version.
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Chapter 13

DIAGNOSTICS
Chapter 13 - Di agnosti cs

The Diagnostics Pane displays issues in the workpaper that currently prevent it from being complete.
To use the Diagnostics Pane, do the following:

1. Click Diagnostics Pane on the Knowledge Coach ribbon. The Diagnostics Pane displays at the
bottom of the workpaper. The type of diagnostic is listed in the left column, and the description
is listed in the right column.
2. Click Type to filter the list of diagnostics. A list of diagnostic types applicable to the open
workpaper displays. Leave the diagnostics types checked if you want to see them in the list.
3. Double-click the blue arrow in any diagnostic row to move to the affected cell in the workpaper.
Notes:
Cells in tables that have open diagnostics are indicated by their light-blue shading. See Cells
with Open Diagnostics on page 27 for more details.
To find a diagnostic in the Diagnostics Pane from a cell that has an open diagnostic, click Find
Diagnostic from the Diagnostics group on the Knowledge Coach ribbon.
The Diagnostics Pane can be moved and resized.

Diagnostics in the Binder Frame
You can tell if a particular Knowledge Coach workpaper has open diagnostics by looking for the Open
Diagnostics icon in the Diagnostic column next to each workpaper name in the binder frame. Click the
workpaper name to display the details of the diagnostics.
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Notes:
When you open a binder, a message displays asking if you would like to refresh the diagnostics
for your Knowledge Coach workpapers. Choose one of the following:

Refresh diagnostics. Updates the diagnostics for all workpapers in the binder.
Do not refresh diagnostics. Keeps the current diagnostics for all workpapers in the
binder.
Select Do not show this message again to stop the message from appearing when
you open a binder. If you select this option, you have to manually refresh diagnostics
when you open binders to get the latest diagnostics information.
Select Prompt when/for : Refresh all diagnostics when Knowledge Coach
binder opens from the Tools > Options menu in the File Room or binder frame to see
the message automatically display when you open a binder.
To manually refresh the diagnostics, right-click on the Refresh Diagnostics item in the
Diagnostics Pane and choose either Refresh diagnostics for this workpaper or Refresh
diagnostics for the entire binder .
If a workpaper has more than one open diagnostic, the Diagnostic icon displays with a plus sign
next to it.
When you sign off on a Knowledge Coach Word workpaper, you are warned if there are open
diagnostics on the selected workpaper.
When you finalize a binder, you are prompted to clear any diagnostics that remain open in
Knowledge Coach workpapers.

Diagnostic Summary
You can view all Knowledge Coach diagnostics across workpapers via the Diagnostic Summary. To
use the diagnostic summary, do the following:

1. Access the diagnostic summary via the View menu in Engagement or the shortcut appearing to
the left of the binder frame.
2. Double-click the blue arrow in any diagnostic row to open the workpaper and move to the
affected cell. See Knowledge Coach Tables on page 25 for more details.
All diagnostics will display by default. You can filter diagnostics using the two buttons at the top to
select the workpaper tab or individual workpapers. You can also filter diagnostics by diagnostic type,
current editor, preparer or reviewer by clicking in the column header of the diagnostic grid.

Deleting a Diagnostic
If you have the appropriate staff group rights, you can delete an open diagnostic that you do not want
to reappear. For example, you may want to delete a diagnostic for “Missing Workpaper – Engagement
Letter” if you already have a scanned copy of the signed Engagement Letter from your client, and you
therefore do not want to use the sample engagement letter provided by the Knowledge Coach title.
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All diagnostics must be deleted before you can finalize the binder.
To delete a diagnostic, do the following:

From the Diagnostic Pane
1. Open the Diagnostics Pane from either the binder frame or from an open Knowledge Coach
Word workpaper and select the diagnostic you want to delete.
2. Click Delete Diagnostic on the Diagnostics group on the Knowledge Coach ribbon. You will be
asked to confirm the deletion.
3. Click Yes.

From the Diagnostic Summary
1. Open the Diagnostic Summary and select the diagnostic(s) you want to delete.
2. Click the Delete button above the grid. You will be asked to confirm the deletion.
3. Click Yes.
Notes:
You can also right-click on an open diagnostic and choose Delete Diagnostic.
In the Diagnostic Summary, you can also delete a diagnostic by using the Delete key on the
keyboard.
Multiple diagnostics can be deleted at once from the Diagnostic Summary.
Some diagnostics which impact the functionality of workpapers cannot be deleted. For example,
Duplicate workpaper and Obsolete Workpaper diagnostic.
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Chapter 14

COPYING AND PASTING KNOWLEDGE
COACH WORKPAPERS
Chapter 14 - Copyi ng and Pasti ng Knowl edge Coach W orkpapers

You can copy and paste Knowledge Coach workpapers from one binder to another, allowing you to
benefit from work you do in one binder that can be reused and then tweaked for a similar
engagement.
To copy Knowledge Coach workpapers to another binder, do the following:

1. Select the workpapers you want to copy and click Edit > Copy.
2. Navigate to the binder into which you want to paste the workpapers and select a tab in that
binder.
3. Click Edit > Paste . The Selected Workpaper Properties window displays. See Inserting
Knowledge Coach Workpapers on page 10 for more details on this window.
4. Click OK when you’re ready to continue. The workpapers are pasted into your binder.
Warning! In the Diagnostics Pane, right-click on the Refresh Diagnostics item and choose either
Refresh diagnostics for this workpaper or Refresh diagnostics for the entire binder . You
should perform this step to ensure that you are working with the most recent diagnostic
information.
Notes:
If no Knowledge Coach workpapers exist in the binder for the selected title into which you are
pasting, the foundation workpapers will be inserted in addition to the workpapers you selected to
copy. For more information, see Foundation Workpapers on page 15.
If Knowledge Coach workpapers exist in the binder but are a different title, related workpapers
and the foundation workpapers will be copied in the binder into which you are pasting.
If you copy an instance of AUD-800 Audit Program – (Custom) into a new binder, the custom
audit area that is associated with the custom audit program must already exist in the new
binder. For more information, see Audit Areas on page 36 and Associate Workpaper on
page 15.
If you copy an associated workpaper into a new binder, the same association must be already
exist in KBA-101 in the new binder before you paste. See Associate Workpaper on page 15.
Since you are not permitted to have duplicate copies of certain Knowledge Coach workpapers
(for example, KBA-101 Overall Audit Strategy), you will not be able to copy these workpapers if
the workpaper already exists in the binder into which you are pasting.
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If you copy a related Knowledge Coach workpaper into a binder that does not yet contain
Knowledge Coach workpapers, all related workpapers for the selected title family will be pasted
into the target binder. If the target binder does contain Knowledge Coach binders for that title
family, any related workpapers that do not exist in the target binder will also be pasted. See
Related Workpaper Links on page 23 for more information.
If you copy independent workpapers only, related workpapers and the foundation workpapers
will not be copied. Only the selected independent workpapers will be copied in the binder into
which you are pasting.
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Chapter 15

SYNCHRONIZING KNOWLEDGE COACH
WORKPAPERS
Chapter 15 - Synchroni zi ng Knowl edge Coach W orkpapers

Synchronizing Knowledge Coach workpapers works the same as other Engagement workpapers, with
a few important differences, as follows:
Since Knowledge Coach workpapers are tied together through the logic, tailoring, information
flow, and diagnostics, you must synchronize certain Knowledge Coach workpapers together as a
set. If any related Knowledge Coach workpapers are selected for synchronization, all related
and Foundation workpapers will also be synchronized automatically. See Related Workpaper
Links on page 23 and Foundation Workpapers on page 15 for more information.
When synchronizing from an open binder, all Knowledge Coach workpapers must be closed. If
you are synchronizing with another local file room, the Knowledge Coach workpapers in the
remote binder must also be closed.
Synchronization of Knowledge Coach workpapers will be canceled if there are sets of
workpapers from the same title of a different version. Any conflicts will need to be resolved
before you can synchronize the binder. Multiple instances of a single instance workpaper will be
detected after the synchronization process has been completed and you open the binder or
perform any Knowledge Coach function. Any duplicate workpaper conflicts will need to be
resolved before you can perform any Knowledge Coach function.
After synchronizing Knowledge Coach workpapers, you should manually refresh the diagnostics
in the binder to ensure you are working with the latest diagnostic information. You will be
prompted to refresh the diagnostics and other data when you open the binder after
synchronization. Alternatively, in the Diagnostics Pane, right-click on the Refresh Diagnostics
item and choose either Refresh diagnostics for this workpaper or Refresh diagnostics for
the entire binder .

Note : When you synchronize a binder that contains Knowledge Coach workpapers and new
content exists in the Knowledge Coach Content Library, only the content associated with the
binder will synchronize.

Resolving Duplicate Workpaper Conflicts
After synchronization, you may be warned of a duplicate workpaper conflict when opening a binder or
attempting to work with a Knowledge Coach workpaper. You are required to resolve the conflict before
working with the workpaper. On the Duplicate Workpaper dialog, you can see all workpapers in
conflict and select the copy to keep.
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If more than one workpaper is duplicated, you will see multiple sections in the dialog separated by
color. Select one workpaper from each section to retain. Information about each workpaper will be
available to help you select which workpaper should be retained.
When deciding which workpaper to keep, consider the following:
If both foundation and related workpapers are duplicated, select workpapers from the same
source. If one set of foundation workpapers is deleted, any related workpapers that went with
that set of foundation workpapers will no longer function. You will be notified of any nonfunctioning workpapers via diagnostic.
You must choose one workpaper from each section to resolve any conflicts. You cannot resolve
duplicate workpaper conflicts for one section and leave another section with conflicts.
Workpapers that are not selected to retain will be automatically deleted. As part of the delete process,
if you are not current editor of the unselected workpaper, you will automatically take over that
workpaper.

Warning! You can choose not to resolve a conflict and close the dialog; however, you cannot
perform any Knowledge Coach functions or work with any Knowledge Coach workpapers until the
conflict is resolved.
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Chapter 16

ROLLING FORWARD KNOWLEDGE COACH
BINDERS
Chapter 16 - Rol l i ng F orward Knowl edge Coach Bi nders

You roll forward a binder that contains Knowledge Coach workpapers in much the same way you roll
forward other Engagement binders. You can manage whether workpapers are replaced with a later
version of the template and how information you provided in the workpapers is treated in the binder
for the next period.
To modify the roll forward settings of a workpaper, do the following:

1. Select a Knowledge Coach workpaper and click File > Properties. The Workpaper Properties
window displays.
2. Modify to the settings and click OK.
For more information, see Keeping Answers to Questions below and Keeping Row Customizations
and Program Steps on page 66.

Keeping Answers to Questions
The Knowledge Coach workpapers have already been analyzed to determine in which areas of the
workpapers you are likely to want to keep your information from period to period, and in which areas
you will want to answer from scratch each period. You can use these default roll forward settings if you
wish by leaving the Data Retention Option set to “Use response roll forward setting.”
To see the cells of a particular table in a Knowledge Coach Word workpaper that are set to be kept, do
the following:

1. Click anywhere inside the table.
2. Click Roll Forward Settings > View Responses Set to Keep on the Complete Cells group
on the Knowledge Coach ribbon.
3. Wait a few seconds for the workpaper to refresh. In each of the cells for which the default roll
forward setting is “keep,” the Keep Upon Roll Forward icon is displayed.
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To see the cells of a particular table in a Knowledge Coach Word workpaper that are set to be reset,
do the following:

1. Click anywhere inside the table.
2. Click Roll Forward Settings > View Responses Set to Reset on the Complete Cells group
on the Knowledge Coach ribbon.
3. Wait a few seconds for the workpaper to refresh. In each of the cells for which the default roll
forward setting is “reset,” the Reset Upon Roll Forward icon is displayed.
Notes:
All of the cells within a column will have the same setting: either keep or reset.
You can continue working in the Knowledge Coach workpaper while the roll forward setting icons
are displayed.
You can override the default roll forward response settings at the workpaper level by choosing
either “Keep all responses” or “Reset all responses” in the Workpaper Properties window.
These settings are not applicable to Knowledge Coach Excel® workpapers, Correspondence
Documents (CORs), Auditor's Reports (RPTs), or Resource Documents (RESs), as they do not
contain answer selection boxes or floaties.

Saving Knowledge Coach Answers
If Microsoft ® Word or Engagement experienced an unexpected shutdown while the current editor was
editing a read-only workpaper, complete the following in order to save your Knowledge Coach
answers:
In the Binder view, select Tools > Save Knowledge Coach Answers.

Warning!
If working in Microsoft ® Word, this option must be selected before re-opening the workpaper
that experienced a problem.
If working in Engagement, this option must be selected after opening Engagement but before
re-opening the workpaper that experienced a problem.
For read-only workpapers, this option must be ran before the workpaper is closed, or the data
will not be saved.

Note : If you attempt to close or save a read-only workpaper and are the current editor of the
workpaper, a read-only message will appear. You must select Save Knowledge Coach
Answers before selecting OK on the read-only message.
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Keeping Row Customizations and Program Steps
You can choose how changes to rows in Knowledge Coach tables are handled when you roll forward
your workpapers. You can also choose how program steps in substantive audit programs are treated.

Row Customizations. If you choose to “Merge Row Customization,” any rows that are added
to or deleted from the current workpaper , as well as text changes to rows within tables will be
merged with the content from the new Knowledge Coach workpaper when it is created. These
items can be reviewed upon opening the rolled forward workpaper in the new binder.
Note : This option does not apply to audit programs. Custom steps in audit programs can
be identified in the program step library.
Keeping Program Steps. If you choose to “Keep Program Steps,” the program steps in the
workpaper that were added from the Program Step Library will be retained in the new
workpaper. This option is only available for audit programs for the substantive audit areas where
the Program Step Library is used. If you choose this option, two other options are available:
Keep Custom Program Steps. Custom program steps you create from scratch in
audit program workpapers will be kept in the new workpaper.
Keep Modified Program Steps. Modifications you make to added program steps in
audit workpapers will be kept in the new workpaper.
Note : If a step is removed in a later version of Knowledge Coach, modifications for
that step are not kept.
Note : Row customization and program step retention settings are not applicable to Knowledge
Coach Excel® workpapers, Correspondence Documents (CORs), Auditor's Reports (RPTs), or
Resource Documents (RESs).

How to Roll Forward a Knowledge Coach Binder
To roll forward a binder that contains Knowledge Coach workpapers,

1. Select the binder to roll forward.
2. Click Tools > Roll Forward Binder . The Roll Forward Binder Wizard displays.
3. Follow the on-screen directions on the Roll Forward Binder Wizard. The Knowledge Coach
workpapers are rolled forward along with your other Engagement workpapers.
4. Wait a few minutes for the binder to refresh. This will ensure you are working with the most
current information in all of your Knowledge Coach workpapers.
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Warning! After you roll forward a binder that contains Knowledge Coach workpapers, make sure
to refresh the diagnostics and other data by choosing Yes when you are prompted when you open
the binder after the roll forward. Alternatively, right-click the Refresh Workpaper Diagnostic in
the Diagnostics pane and select Refresh Diagnostics for the Entire Binder . This ensures that
the resetting of information flow is properly refreshed. If you do not do this, you may see prior
period information appear in workpapers if you open a workpaper out of the order of its
information flow, since the data retention settings do not take effect until you open each
workpaper.
Note : You can modify the roll forward settings of Knowledge Coach workpapers and select the
appropriate later version, if applicable, during the Roll Forward process.
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Chapter 17

GUIDANCE
Chapter 17 - Gui dance

Knowledge Coach Guidance
To obtain supplemental guidance related to a Knowledge Coach title, do the following:

1. Open any Knowledge Coach workpaper.
2. Click KC Guidance on the Guidance group on the Knowledge Coach ribbon. A help file
displays. This help file contains the same content as RES-001 KBA Methodology Overview. It
also contains workpaper-specific help, including tip information, content updates, and answer
effects.

Accessing CCH Accounting Research Manager
To access CCH Accounting Research Manager (ARM) from within a binder, do the following:

1. Open the binder.
2. Select Guidance on the Shortcut bar.
3. Click the CCH Accounting Research Manager icon.
4. Enter your User Name and Password and click OK. You do not have to enter your User Name
and Password if it has been entered in your staff profile in Engagement Administrator.
You can also access CCH Accounting Research Manager by going directly to
http://www.accountingresearchmanager.com.
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